Closed Bug 494742 Opened 10 years ago Closed 10 years ago

Update shipped copy of blocklist.xml

Categories

(Firefox :: General, defect)

3.5 Branch
x86
All
defect
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
status1.9.2 --- beta2-fixed
status1.9.1 --- .6-fixed

People

(Reporter: nthomas, Assigned: mossop)

References

Details

(Keywords: verified1.9.1)

Attachments

(1 file, 2 obsolete files)

Attached patch Update blocklist.xml (obsolete) — Splinter Review
Here's the diff on mozilla-1.9.1 to 
https://addons.mozilla.org/blocklist/1/%7Bec8030f7-c20a-464f-9b0e-13a3a9e97384%7D/3.5/
It appears to be removing a couple of Firefox version limits.

Note
* the URL is assuming that no platform-specific blocking is going on
* depends on resolution in bug 479095 - it's desirable (but maybe not mandatory) to include AVG in the shipped file if we're going to block it
Flags: blocking-firefox3.5?
Flags: blocking-firefox3.5? → blocking-firefox3.5+
For now there is nothing to do here. The correct URL to use for Firefox 3.5 and later is:

https://addons.mozilla.org/blocklist/3/%7Bec8030f7-c20a-464f-9b0e-13a3a9e97384%7D/3.5/Firefox/20090105024647/blocklist-sync/en-US/nightly/blocklist-sync/default/default/

The versionRange entries that are missing in the url in comment 0 is because the old schema did not support versionRange entries for plugins.

Not sure whether it is worth holding this open in case bug 479095 is resolved or not. I know there are a few other blocklist bugs that might be fixed in the meantime too.
Oh, if we're already using the right URL and have content there, then this doesn't need to block. I'd rather block on individual issues like bug 479095 instead of a metabug.

Should this be resolved invalid?
Flags: blocking-firefox3.5+ → blocking-firefox3.5-
(In reply to comment #2)
> Oh, if we're already using the right URL and have content there, then this
> doesn't need to block. I'd rather block on individual issues like bug 479095
> instead of a metabug.
> 
> Should this be resolved invalid?

The issue is that as entries are added to the blocklist database we also should update the in-tree copy of blocklist.xml, since we haven't yet got this working automatically in mercurial like we have in cvs. However it isn't critical, it is just about giving new users the most up to date blocklist instantly.

We can just close this if you like, but if any changes to the blocklist are made and we are going to spin a new RC then I'll still be bugging you for approval to land the blocklist changes in tree.
Attached patch update blocklist.xml (obsolete) — Splinter Review
Finding it difficult to track exactly when updates to the blocklist are pushed but I think this change was too late to make it into 3.5 final anyway. But we should land it on branch and trunk.
Assignee: nobody → dtownsend
Attachment #379506 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Dave: is this now fixed, 3.5.1 is out :-)
(In reply to comment #5)
> Dave: is this now fixed, 3.5.1 is out :-)

No, see comment 4
Comment on attachment 387009 [details] [diff] [review]
update blocklist.xml

Mike, before landing updates to the copy of the blocklist that we ship with the application beltzner would just like someone to assert that these changes match those made on the server.

This just adds the block from bug 479095.
Attachment #387009 - Flags: review?(morgamic)
Summary: Update shipped copy of blocklist.xml before 3.5rc1 builds → Update shipped copy of blocklist.xml
Attachment #387009 - Attachment is obsolete: true
Attachment #387009 - Flags: review?(morgamic)
Depends on: 512406
Mike, can you confirm that these were the changes to the blocklist from the two dependant bugs, then I can land this and it can be included in Firefox installs.
Attachment #404126 - Flags: review?(morgamic)
Well it's just a diff between the result of the url in comment 1 and the current version in tree, but apparently I need to get someone to agree it is right.
Comment on attachment 404126 [details] [diff] [review]
updated blocklist.xml

Looks like we're just picking up stuff that's currently served.  Looks good to me.
Attachment #404126 - Flags: review?(morgamic) → review+
Landed on trunk with one minor change: http://hg.mozilla.org/mozilla-central/rev/f3e9ac90c086
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Attachment #404126 - Flags: approval1.9.2?
Attachment #404126 - Flags: approval1.9.1.5?
Blocks: 525465
Comment on attachment 404126 [details] [diff] [review]
updated blocklist.xml

Approved for 1.9.1.6, a=dveditz for release-drivers
Attachment #404126 - Flags: approval1.9.1.6? → approval1.9.1.6+
Flags: blocking-firefox3.6?
While this doesn't add the Skype blocking, could we get an a1.9.2+ on attachment 404126 [details] [diff] [review] before 3.6b2 spins ?
Comment on attachment 404126 [details] [diff] [review]
updated blocklist.xml

a=shaver
Attachment #404126 - Flags: approval1.9.2? → approval1.9.2+
Flags: blocking-firefox3.6? → blocking-firefox3.6+
Verified for 1.9.1 in source. Nothing else to do here.
Keywords: verified1.9.1
You need to log in before you can comment on or make changes to this bug.