Closed Bug 494747 Opened 11 years ago Closed 10 years ago

Enable push-to-try for the comm-central try server

Categories

(Mozilla Messaging :: Try Server, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: philor, Assigned: gozer)

References

()

Details

Attachments

(1 file)

I might have used the patch-upload method for the mozilla-central try server once, can't really remember. The push-to-try method, however, I use every single time I'm going to push a checkin-needed patch for someone else, every single time I think I should be sure a patch works on more than just whichever OS I'm currently on, and every single time I don't feel like sitting through running tests myself. No matter how small the difference in actual effort, the cognitive difference between "hg qdiff > ../foopy, open a browser, try to remember the URL, ask on IRC, wait, load a web page, select a cert, upload a patch, um what did I name it" and "hg push -f cc-try" is *massive*.
Depends on: 494774
That's a very good idea, I've filed a Mozilla IT bug request to get a comm-central-try repository created to support this.
No longer depends on: 494774
<http://hg.mozilla.org/try-comm-central> has been created. Now need to fiddle with the try-server configuration to pull from there.
Okay, I've populated try-comm-central with comm-central, and I've managed to push a mq patch to it, great.

Still broken, as the tryserver recieves the change, but gets confused when it's time to determine what it should be building. Right now, it's failing to pick a mozconfig, but I suspect there will be more bustage. Needs more work.
Duplicate of this bug: 513836
Assignee: nobody → gozer
Component: Release Engineering → Try Server
QA Contact: release → try-server
You can now push to hg.mozilla.org/try-comm-central
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
This patch allows creating try-builds of Lightning. I am piggybacking this bug with permission :-)
You need to log in before you can comment on or make changes to this bug.