Dropdown placement wrong on dual-display setup

RESOLVED INCOMPLETE

Status

()

--
minor
RESOLVED INCOMPLETE
9 years ago
8 years ago

People

(Reporter: tribbin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2010-09-15])

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10

At work I have a dual-headed monitor setup where the screens are at diffent heights. In my case the left monitor is lowered by aprox. one-third of the monitor-height. In windows my monitor properties are adjusted to this situation.

When I have a webpage with a dropdown menu on my left monitor, it will 'pop' upwards beyond my screenborder; there is no way to click on the items that are heighest in the dropdown-list.

I suspect that firefox treats this screen as if the top-border is at the height of my 'heighest' monitor.

Reproducible: Always

Steps to Reproduce:
1. Create horizontal dual-head monitor setup where the screens are leveled at different heights.
2. Open a webpage with a large dropdown-list on the 'lower' monitor
3. Open dropdown
Actual Results:  
Dropdown pops upwards beyond the screen-border.

Expected Results:  
Dropdown should recognize screen-edge and pop according to this.

I made a screenshot that shows this problem and I will try to supply this.
(Reporter)

Comment 1

9 years ago
Created attachment 379546 [details]
Dual-headed setup with dropdown on the left screen (texts sensored due to sensitive information)

Comment 2

8 years ago
Do you still see this problem using the newest versions of Firefox (3.6)?

If you do not, please close the bug with resolution set to WORKSFORME (after staus=RESOLVED). If problem was caused by add-on or non-mozilla code please use INVALID resolution.
If you do still see the problem, please comment in the bug.
Whiteboard: [closeme 2010-09-15]
No reply, INCOMPLETE. Please retest with Firefox 3.6.10 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.