Can't fwd an email msg due to div tag in HTML signature file

VERIFIED WORKSFORME

Status

P3
normal
VERIFIED WORKSFORME
19 years ago
11 years ago

People

(Reporter: johng, Assigned: vparthas)

Tracking

Trunk
x86
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-] relnote-user)

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
build 2000081608, POP, Win95

In general I can fwd any message in my inbox, except for this ONE message.  I'll 
attach it.  Only things unique about this message that I could see are:

> the message has already been forwarded several times before it got to me.
> original message was written using a different email system (I think)
> when I try to forward it, the mail compose window opens but puts all except 
for the last fwd comment into an attachement (can't bring it inline).  

Reproduce steps:
>  select this particular message, click "Fwd"  
>  in mail compose window, notice that all except the last comment is attached 
as a separate file (Note, you can also use the menu to chhose "fwd inline" and 
the results are the same)
> click "Send", the dialog opens about if I want to send it as html, etc, then 
click "Send" again
> nothing happens.  It is not sent, the mail compose window just sits there.

Updated

19 years ago
QA Contact: lchiang → esther
(Reporter)

Comment 1

19 years ago

Comment 2

19 years ago
mark it Netscape only - msg looks like it talks about a security problem
Group: netscapeconfidential?

Comment 3

19 years ago
Can someone try this out and see if it's reproduceable?
Keywords: nsbeta3

Updated

19 years ago
Whiteboard: [b3 need repro]
(Reporter)

Comment 4

19 years ago

Comment 5

19 years ago
I had john send me a folder with that message in it so I could see the message 
as he was seeing it.  I reproduced the problem, so I copied the folder with the 
bad message to my 4.7 pop account and tried to forward it from there.  I get a 
Netscape error "A communications error occurred.  Please try again", and it 
doesn't send.  Not sure what the problem is, Scott do you have any ideas.  

Comment 6

19 years ago
I think I tracked this down (thanks to Peter).  The problem is in Michaell's 
signature.  In the source it shows he uses <div class="signature">, in an old 
composer bug 33213 it states using <div> causes problems.  In one comment it was 
suggested using <p> instead of <div>, so I tried that.  I edited this bad 
message in notepad, preplacing the <dev> with <p>, saved it, retrieved it.  It 
visually looked the same and I was able to Forward it.  So this could be a 
duplicate of bug 33213 but I'll let ducarroz review this and give his comments. 
 

Comment 7

19 years ago
remove b3 need repro info for evaluation by mailtriage

Great work, Peter and Esther!
Whiteboard: [b3 need repro]
<div class="signature"> was added by Message compose until few weeks ago. We 
don't do this anymore. But, I wont be surprised if somebody add a div in his 
HTML signature file. Therefore we should find a fix to this problem...
Status: NEW → ASSIGNED
Target Milestone: --- → M18

Updated

19 years ago
Summary: Can't fwd an email msg → Can't fwd an email msg due to div tag in HTML signature file

Comment 9

19 years ago
- per mail triage.  We'll release note this
Keywords: relnote3
Whiteboard: [nsbeta3-]

Updated

19 years ago
Keywords: relnoteRTM
Whiteboard: [nsbeta3-] → [nsbeta3-] relnote-user
can we please invalidate this bug and create a new cleansed version without the
confidential attachment.  This bug doesn't appear to have anything to do with
security.  Thanks.
this attachment doesn't appear to have any security related informaion.  Can we
please open this bug or file a new one. 
Target Milestone: M18 → ---
without comment reopening
Group: netscapeconfidential?
(Assignee)

Comment 13

18 years ago
re-assign to varada
Assignee: ducarroz → varada
Status: ASSIGNED → NEW

Comment 14

18 years ago
Testing with Mozilla 0.9.6, this bug seems INVALID. I tested forwarding as the
three types of Inline as well as Attachment and all emails went out and came
back in properly. The following was my test message:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html lang="en" xml:lang="en-CA" xmlns="http://www.w3.org/1999/xhtml">
<head>
<title>An email.</title>
</head>
<body bgcolor="#ffffff">
Foo.
Bar.
<div class="signature">
See the error?
</div>
</body>
</html>

Comment 15

17 years ago
I also tried forwarding this mail and had no problems. Tried as attachment and
inline and it worked...
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 16

17 years ago
Verified.
Status: RESOLVED → VERIFIED

Comment 17

17 years ago
*** Bug 144732 has been marked as a duplicate of this bug. ***

Comment 18

17 years ago
Is this still a problem since it is in the 1.0 rel notes? Otherwise I would
advice it to be removed from there.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.