[Central-European languages] Cannot add contacts if Thunderbird interface is set to non-English

RESOLVED FIXED

Status

Thunderbird
Address Book
--
critical
RESOLVED FIXED
8 years ago
5 years ago

People

(Reporter: Răzvan Sandu, Assigned: Alexandru Szasz)

Tracking

({dataloss})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; ro; rv:1.9.0.10) Gecko/2009042523 Ubuntu/9.04 (jaunty) Firefox/3.0.10
Build Identifier: version 2.0.0.21 (20090409)

I am running a stock Ubuntu 9.04 machine, with stock Thunderbird 2.0.0.21.

The system is set to Romanian language.

UTF-8 is set in Thunderbird -> Preferences -> Display -> Fonts -> Character Encoding (both drop lists; "Use default encoding in replies" is checked).

When sending e-mails, contacts are automatically added to "Personal Address Book" as usual.

However, when trying to manually add a contact in the addressbook, the following error message pops up, denying operation:

<!DOCTYPE overlay SYSTEM "chrome://messenger/locale/addresbook/abcardOverlay.dtd">

Setting the Ubuntu system in English (form the System menu - Language support) solves the problem, so I guess is a matter of encoding/localization.

I guess the bug is not specific to Romanian language.


Reproducible: Always

Steps to Reproduce:
1. Set a stock Ubuntu 9.04 system with Romanian interface
2. Install Thunderbird from official repository
3. Try to manually add a new contact in the AddressBook

Actual Results:  
When trying to manually add a contact in the addressbook, the following error message pops up, denying operation:

<!DOCTYPE overlay SYSTEM "chrome://messenger/locale/addresbook/abcardOverlay.dtd">

Expected Results:  
Adding contacts and lists should perform normally.



The following Unicode codes are widely used in Romanian language (not exclusively):

0218, 0219, 021A, 021B

System-wide support for Romanian language is correctly implemented in current Ubuntu, Fedora, Debian and probably others (still not in CentOS 5.3).
Can you go to Tools -> Error Console and see if anything appears when you try to manually add a contact? If so copy and paste it here please.
(Assignee)

Comment 2

8 years ago
It's a localization fault, but Thunderbird 2 is not available in Romanian, there is just a language pack on addons.mozilla.org.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Updated

8 years ago
Assignee: nobody → alexxed
(Assignee)

Comment 3

8 years ago
Could not reproduce the bug with the addon. It might be a problem only on Ubuntu.
(Reporter)

Comment 4

8 years ago
@mark

Hello,

I'm getting two errors:

Eroare: OnLoadNewCard is not defined
Fișier sursă: chrome://messenger/content/addressbook/abNewCardDialog.xul
Rândul: 1

Eroare: NewCardOKButton is not defined
Fișier sursă: chrome://global/content/bindings/dialog.xml
Rândul: 356

Regards,
Răzvan

Comment 5

7 years ago
This bug is obsolete? Perhaps fixed?
(Reporter)

Comment 6

7 years ago
Thanks - it is fixed in Ubuntu 10.10 that I'm running now, I cannot verify for the initial Ubuntu version (9.04).

Răzvan

Updated

7 years ago
Blocks: 632886
Severity: major → critical
Keywords: dataloss

Comment 7

5 years ago
Razvan, perhaps this bug is resolved now?

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.