If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Bring the AMO2009/ClearLeft sexy back to the Version History page

VERIFIED FIXED in 5.0.6

Status

addons.mozilla.org Graveyard
Public Pages
VERIFIED FIXED
8 years ago
2 years ago

People

(Reporter: stephend, Assigned: wenzel)

Tracking

unspecified
5.0.6
Dependency tree / graph

Details

(URL)

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

8 years ago
Word.
Target Milestone: --- → 5.0.6

Updated

8 years ago
Blocks: 495070
(Assignee)

Comment 1

8 years ago
Picking this up.
Assignee: nobody → fwenzel
Hardware: x86 → All
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)
> Picking this up.

It was the sexy in the summary, wasn't it? <3
(Assignee)

Comment 3

8 years ago
Oh, you know me so well, Stephen ;)
(Assignee)

Comment 4

8 years ago
Created attachment 380227 [details] [diff] [review]
Patch, rev. 1

I hope I win the price for the most ugly code removed in one day with this one ;)

This contains the reskin that I made for the version history page, but I also had to redo the "latest compatible version" detection which was majorly broken. As a side effect, this also fixes bug 475825.

I'll attach two example screenshots as well, so you can see what you *should* be seeing. QA: That's for you, later, also.
Attachment #380227 - Flags: review?(clouserw)
(Assignee)

Comment 5

8 years ago
Created attachment 380228 [details]
Screenshot: Regular behavior
(Assignee)

Comment 6

8 years ago
Created attachment 380231 [details]
Screenshot: Experimental Add-on version
(Assignee)

Comment 7

8 years ago
By the way: The patch contains two little png icons, so you want to use `git apply` to apply the patch.
(Assignee)

Updated

8 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

8 years ago
Blocks: 487505
omg

That said, there are no images in the patch.  Did you --binary it?
(Assignee)

Comment 9

8 years ago
Created attachment 380277 [details] [diff] [review]
Patch, rev. 2

I forgot the --binary flag, thanks!
Attachment #380227 - Attachment is obsolete: true
Attachment #380277 - Flags: review?(clouserw)
Attachment #380227 - Flags: review?(clouserw)
Comment on attachment 380277 [details] [diff] [review]
Patch, rev. 2

This touches a lot of code so it has the potential to break stuff.  It WFM in my tests though, so I'll r+.  The page looks good.
Attachment #380277 - Flags: review?(clouserw) → review+
(Assignee)

Comment 11

8 years ago
r26542. Agreed, let's hope it didn't break anything more horribly than it was broken before. I made sure though that the install buttons still look reasonable in other places, after I removed the hideous version history hack from it.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Keywords: push-needed
Resolution: --- → FIXED
(Assignee)

Updated

8 years ago
Blocks: 495393
(Assignee)

Updated

8 years ago
Blocks: 475825
(Reporter)

Comment 12

8 years ago
The above URL has a self-linking breadcrumb :-(
(Assignee)

Comment 13

8 years ago
Where else would the last one point?
(Reporter)

Comment 14

8 years ago
(In reply to comment #13)
> Where else would the last one point?

Nowhere -- it's redundant.
(Assignee)

Comment 15

8 years ago
Removed in r26548. NB: The string it used ("version history with change logs") was present on the old page and is now gone from the page.
(Reporter)

Comment 16

8 years ago
Thanks, Fred -- this makes the page consistent with the other places we're using the breadcrumb.

Verified FIXED
Status: RESOLVED → VERIFIED

Updated

8 years ago
Duplicate of this bug: 487462
(Reporter)

Comment 18

8 years ago
removing "push-needed" from 105 AMO 5.0.6 bugs; filter on "I hate stephend!"
Keywords: push-needed
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.