FF hangs if script loaded from HTTPS connection gets blocked by proxy

RESOLVED DUPLICATE of bug 492459

Status

()

defect
--
major
RESOLVED DUPLICATE of bug 492459
10 years ago
10 years ago

People

(Reporter: hsn, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; cs; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; cs; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 (.NET CLR 3.5.30729)

Firefox can correctly detect if HTTPS page gets blocked by proxy server. Typing https://blockedsite into address bar doesnt hangs him.

But if request to blocked https site is from <script tag> FF networking hangs in (Transfering data from on statusbar) and cant even detect that proxy server closed TCP connection after timeout.

Response from proxy server is following:
-> CONNECT ad.doubleclick.net:443 HTTP/1.1
-< HTTP/1.0 403 OK
-< Content-type: text/html
-< Content-length: 337
-< Proxy-Connection: Keep-alive
[... html formated error message from proxy ...]

offending part of JS:
<!-- DoubleClick Random Number -->
<script language="JavaScript" type="text/javascript">
   dfp_ord=Math.random()*10000000000000000;
   dfp_tile = 1;
</script>   
                        <script type="text/javascript">
                        //<![CDATA[
                        document.write('<script src="https://ad.doubleclick.net/adj/ostg.sourceforge/project_web_p85_skybox;pg=default;dcopt=ist;tile='+dfp_tile+';     tpc={SFN-APPNAME};tpc=scache;ord='+dfp_ord+'?" type="text/javascript"><\/script>');
                        dfp_tile++;
                        //]]>
                        </script>


Reproducible: Always

Steps to Reproduce:
1. Get HTTPS proxy server with URL Filtering. I am using scache.sf.net but others (Squid) should work too.
2. block URL with string *ad.doubleclick.net*
3. test on mantis bug tracker on sf.net https://apps.sourceforge.net/mantisbt/scache/roadmap_page.php



FF 3.0.10
Smart Cache revision 104 from Bazaar repo http://scache.bzr.sourceforge.net/bzr/scache/head/files
Reporter

Updated

10 years ago
Version: unspecified → 3.0 Branch

Comment 1

10 years ago
This seems to be the same issue as:
https://bugzilla.mozilla.org/show_bug.cgi?id=492459
Reporter

Comment 2

10 years ago
Here is dump of Smart Cache console to see what FF is doing:

[TRACE Thread-33] > CONNECT data.coremetrics.com:443 HTTP/1.1
[TRACE Thread-34] > CONNECT ad.doubleclick.net:443 HTTP/1.1
[TRACE Thread-34] ! Blocked https://ad.doubleclick.net:443/
        by ^https?://ads?[0-9]*\.
[TRACE Thread-34] = Waiting for next request on connection.
[1 minute later - input connection timeout]
[TRACE Thread-34] = Input connection timed out.

Last message on status bar is Transfering data from data.coremetrics.com. After input connection timeout Smart Cache closed keep-alive proxy input connection but FF was still hanging.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 492459
You need to log in before you can comment on or make changes to this bug.