Jetpack's status bar panels prevent other add-ons from loading in the status bar

VERIFIED FIXED in 0.5

Status

P1
major
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: mozilla.bugs, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
I have several add-ons that load in the status bar, including Weave, Mozilla QA Companion, Firebug, Personas, etc.

When I installed the Personal Tab Graph for Jetpack, the status bar add-ons were still visible.  After restarting Firefox, the only item on the status bar was the Personal Tab Graph.  Each missing add-on was accessible from another interface, but not visible on the tab bar.

Jetpack: 0.1.5 with Personal Tab Graph
Firefox: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4

I have been able to isolate and reproduce the issue.

Comment 1

9 years ago
Can you reduce this to the simplest possible test case for us to debug with?
Priority: -- → P3

Comment 2

9 years ago
As far as I know, this isn't just specific to the personal tab graph--it's happening whenever Jetpack adds a status bar panel at startup. fligtar and ddahl were both having this problem too, the former on os x and the latter on linux.  ddahl found that the problem only occurred on the first browser window that opened on startup, but subsequent browser windows were fine (i.e., they included both the jetpack-added status bar panel and ones from other extensions).

fligtar had to disable jetpack because of this bug, so i'm pushing this up to P1 and assigning it to myself.
Severity: normal → major
Status: NEW → ASSIGNED
Priority: P3 → P1

Updated

9 years ago
Summary: Jetpack's Personal Tab Graph prevents other add-ons from loading in the status bar → Jetpack's status bar panels prevent other add-ons from loading in the status bar

Comment 3

9 years ago
This could be because our statusbars may have been loading after the initial browser.xul was loaded, but before all its overlays were applied.  I've attempted to fix this here:

  http://hg.mozilla.org/labs/jetpack/rev/7148deb082fb
(Reporter)

Updated

9 years ago
Duplicate of this bug: 495011
(Reporter)

Comment 5

9 years ago
According to Bug 495011, the issue affects Mac OSX, so I am changing the bug to affect All OSes, instead of just Windows XP.
OS: Windows XP → All
Hardware: x86 → All
Marking as Resolved, as Atul thinks this issue was fixed in .4.  I'm running Delicious, Fire Eagle, Firebug, TwitterFox, Glue, and Weave and they seem to play well with jetpack.  Can someone else verify?
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: -- → 0.5
(Reporter)

Comment 7

9 years ago
Verified Fixed with Jetpack 0.4 installed on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a2pre) Gecko/20090908 Namoroka/3.6a2pre (.NET CLR 3.5.30729) ID:20090908044437.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.