missing space in UTF-8 text

VERIFIED DUPLICATE of bug 47154

Status

SeaMonkey
General
P3
normal
VERIFIED DUPLICATE of bug 47154
18 years ago
13 years ago

People

(Reporter: edmundo, Assigned: asa)

Tracking

({verifyme})

Trunk
x86
Linux
verifyme

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
NOSXPAMchenero@get2net.dk noted that the following is incorrectly
rendered without the space between "unu" and "du":

<html><head>
<meta http-equiv="Content-Type"
content="text/html; charset=utf-8" />
</head><body>
unu
du &#256;
</body></html>

Comment 1

18 years ago
This looks a lot like another DUP of bug 47154, "Line breaks disappear when 
entities present in text (newlines are not converted to spaces) (Newline 
characters do not translate to whitespace) ([TEXT] Certain characters make 
Mozilla run words together)", FIXED 2000-08-15. 
The culprit will be the "&#256;".

edmundo@rano.org, do you know if NOSXPAMchenero@get2net.dk was using a current
nightly or an M17 build?

Comment 2

18 years ago
Created attachment 13174 [details]
Reporter's testcase

Comment 3

18 years ago
edmundo@rano.org reports that the bug was found on PR2 and confirmed on M17.

Testing with 2000-08-19-08-M18 on WinNT, the words on different lines are NOT
run together.

Gonna call this one a DUP of bug 47154; to verify please view attached testcase
on a current Linux nightly.

*** This bug has been marked as a duplicate of 47154 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 4

18 years ago
is this working now, as the otherbug is marked fixed? adding verifyme keyword to
bugs I cannot verify.
Keywords: verifyme
(Assignee)

Comment 5

18 years ago
spaces seem fine.  verifying with 091108 on linux mozilla
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.