Multiple Tags get erased on message move

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
10 years ago
8 years ago

People

(Reporter: ygerman, Unassigned)

Tracking

({dataloss})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/525.19 (KHTML, like Gecko) Chrome/1.0.154.65 Safari/525.19
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090223 Thunderbird/3.0b2

IMAP Back end when applying multiple tags to the message and the message gets moved, the tags get erased and only the first tag applied stays with the message.

All Tags should stay with the message as that defeats the purpose of tags.

Reproducible: Always

Steps to Reproduce:
1. Multiple Tag a message
2. Move message to different folder on IMAP server
3.
Actual Results:  
First Tag stays, rest get removed

Expected Results:  
All Tags are kept

Comment 1

10 years ago
This WFM in recent shredder nightlies, at least with my normal IMAP setup which may differ from yours. It would be good to test this in a recent build, since bug 459680 (which landed after b2) could have affected this - though probably not, since it was focused on local folders. Some questions:

1) Are these folders offline or online?

2) Do you know if your IMAP server supports custom message flags? (or at least give me the type of server)

Perhaps IMAP is for some reason applying the old Label logic (which only supported one label per message). Looking for that, a couple of more questions:

3) Do these message perhaps have old labels applied to them? they might be true if they were old and had been migrated for example.

4) Do you see the same behaviour in a fresh profile?

An IMAP protocol log would also be useful.

Sorry to ask for so much, but I would like to see this fixed if it can be reproduced.
Tb's "tag" is implemented as "user defined keyword of IMAP"(flag/keyword).
Get IMAP log, and check IMAP level flow first, in order to see whether your IMAP server supports "user defined keyword" or not.
  - Getting log : See Bug 402793 Comment #1,  Bug 402793 Comment #6,
                      Bug 402793 Comment #16, Bug 402793 Comment #17
  - IMAP command/response : See http://tools.ietf.org/html/rfc3501
Is there any Tb's fault around tag(flag/keyword) in log?

> Steps to Reproduce:
> 1. Multiple Tag a message
> 2. Move message to different folder on IMAP server

What tag? Tags you defined? Or standard tag(former label) like Important, ..., Later?
Move to folder on same IMAP server? Or different IMAP server?

> xxx@gmail.com

Gmail IMAP?

Comment 3

10 years ago
xref bug 378973

Updated

10 years ago
Severity: major → critical
Keywords: dataloss
(Reporter)

Comment 4

10 years ago
(In reply to comment #1)
> may differ from yours. It would be good to test this in a recent build, since
> bug 459680 (which landed after b2) could have affected this - though probably
> not, since it was focused on local folders. Some questions:

Will Do this but first to answer questions.

> 
> 1) Are these folders offline or online?

Tested with both On-Line and Off-Line with same results.

> 2) Do you know if your IMAP server supports custom message flags? (or at least
> give me the type of server)

Yes, IMAP is Dovecot. Also my understanding is the tags are not transfered to the IMAP server but are stored in a local file (as per reading the 2.X tag information).

> 3) Do these message perhaps have old labels applied to them? they might be true if they were old and had been migrated for example.

No this is new labels / tags.


> 4) Do you see the same behaviour in a fresh profile?

Profile is brand new so it is fresh.
(Reporter)

Comment 5

10 years ago
I just tried the Shredder build and this looks line it is working I well close this for now and red be reopen it again later.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.