Thunderbird to be able to remapped default IMAP folder names

RESOLVED DUPLICATE of bug 182274

Status

RESOLVED DUPLICATE of bug 182274
10 years ago
9 years ago

People

(Reporter: bhun2858, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4
Build Identifier: 

In an imap account there are certain folders with Thunderbird gives arbitary names to certain folders. Some Inbox, Deleted, Unsent Items and Sent. These are folder names that the user sees. On the server side, they might have different names like Trash, Outbox or Sent Items.

The problem is that other email clients may use differnt arbitary folder names. The Outlook.com web client has a default folder for deleted objects arbitarily called "Deleted Items" when you use their web interface, but Thunderbird creates an arbitary folder called "Trash" on the server for deleted objects. The result is that I have 2 folders for deleted items, 2 folders for Unsent emails (outbox) and 2 folders for sent items with each interface using different folders.

Its very confusing when multiple interfaces are being used.

So this bug is a request to be able to map these labels to match any particular folder on the server side.

I would suggest that this option be in Tools -> Account Settings... -> [Account] -> Copies & Folders as well as the Folder properties in the folder pane.

Reproducible: Always
(Reporter)

Updated

10 years ago
Summary: Thunderbird to be able to remapped default IMAP folders → Thunderbird to be able to remapped default IMAP folder names
Whiteboard: dupeme
Brian, please try with a nightly (backing up your profile in the process) to see if this has been fixed, making sure your server supports XLIST, some work was recently done on XLIST support in Thunderbird. Then post your build id if it still occurs.

Nightly location:
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-central/
xref bug 476260

cc bienvenu if he has any thoughts.

Comment 3

10 years ago
It's unlikely that server supports XLIST - GMail does, and I believe dovecot will.

There's a server setting that lets you pick the trash folder for this very reason, in account settings, server settings, "when I delete a message, move it to this folder" with a drop down that will let you pick the other trash folder.
(Reporter)

Comment 4

10 years ago
(In reply to comment #3)
> It's unlikely that server supports XLIST - GMail does, and I believe dovecot
> will.

This sounds complementary to this XLIST function. I havent tried nightlies so i'm being hypothetical - looking at bug 476260, XLIST seems to get folder information from the server to marry up TB folder names. This request manually modify folder locations on the client side to tie in with the server side - i think...

> There's a server setting that lets you pick the trash folder ...... "when I
> delete a message, move it to this folder" with a drop down that will let you
> pick the other trash folder.

The option says "move it to the Deleted folder" - slightly different because it does not allow you to choose what the Deleted folder actually is eg a folder called Trash or Deleted Items on the server.

Comment 5

10 years ago
> The option says "move it to the Deleted folder" - slightly different because it
> does not allow you to choose what the Deleted folder actually is eg a folder
> called Trash or Deleted Items on the server.

I don't remember when this was added, but 3.0 beta builds definitely let you pick a trash folder.
Yup, in bug 182274.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 182274
Cleanup *dupeme* whiteboard flag from bugs that are marked as Resolved Duplicate!
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.