Opacity clipping text by 1px but moz-opacity fine

RESOLVED WORKSFORME

Status

()

Core
Graphics
--
trivial
RESOLVED WORKSFORME
9 years ago
4 years ago

People

(Reporter: Paul Liversidge, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4 (.NET CLR 3.5.30729)

Using opacity <1 through CSS or style attribute clips the right-hand side of the text by 1px. Using -moz-opacity works fine though, suggesting the two properties are being handled differently.

Reproducible: Always

Steps to Reproduce:
1. Use this HTML snippet:

<p style="font-family:Tahoma;">Delete</p>
<p style="font-family:Tahoma;opacity:0.9">Delete</p>
<p style="font-family:Tahoma;-moz-opacity:0.9">Delete</p>
Actual Results:  
The middle paragraph clips the right-hand side of the text by 1px.

Expected Results:  
All three paragraphs should be rendered the same, albeit the slight difference in opacity of the text.

Editing the HTML, or CSS, live through FireBug or the Web Developer toolbar temporarily fixes the problem though.
-moz-opacity isn't supported anymore. It won't have any effect.

The rest of this bug is likely a duplicate of another one, though I can't find it at the moment.
Component: General → GFX: Thebes
Product: Firefox → Core
QA Contact: general → thebes
Whiteboard: DUPEME
(Reporter)

Comment 2

9 years ago
Created attachment 380453 [details]
Screenshot of the problem enlarged by 500%

Particular letters are more obvious than others such as the 'e', 'w', 'v' and 'm' but you can see the clipping is caused by a different anti-aliasing algorithm. The plain and opacity snippets are anti-aliased with color whereas the opacity snippet is anti-aliased with only grayscale and the final column is missing as you can see by comparing the 'e' in the sample.

Comment 3

8 years ago
Hello, this still happens in the latest Mozilla Firefox 3.5.4 for Windows.

When using small font sizes and names ending in letters like 'i' this truncates the latest latter, creating a subtle bug which is really hard to trace.

Comment 4

8 years ago
Created attachment 409060 [details]
Truncation issue

Last letter, if it's narrow, gets truncated with certain font sizes/background colors.

Comment 5

8 years ago
Created attachment 409062 [details]
Mozilla Firefox 3.5.4 rendering of truncation issue

Comment 6

8 years ago
This works for me on the trunk and Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6

Can reproduce using 3.5, would like conformation that the bug is worksforme.

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.