Closed Bug 495117 Opened 10 years ago Closed 10 years ago

-moz-box-sizing: border-box not working for display: table-cell

Categories

(Core :: Layout: Tables, defect)

x86
Windows Vista
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 338554

People

(Reporter: martin_grossi, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 3.5.30729; .NET CLR 3.0.30618)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4 (.NET CLR 3.5.30729)

When creating a DIV element with the following inline styles, the dimensions of the box with border become 102px(width) and 100px(height).
-moz-box-sizing: border-box;
display: table-cell;
width: 100px;
height: 100px;
border: solid 1px red;
padding: 0px;
margin: 0px;

Reproducible: Always

Steps to Reproduce:
1.Set the doctype to <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
2.Create a div element with the given styles
3.
Actual Results:  
Box with red border appears within the browser with overall dimensions of 102px (width) and 100px(height)

Expected Results:  
Box with red border should appear with overall dimenisions of 100px x 100px
Attached file Bug example
Component: General → Layout: Tables
Product: Firefox → Core
QA Contact: general → layout.tables
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 338554
If this is a duplicate bug of 338554 how come it hasn't been fixed since 2006?????
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(In reply to comment #3)
> If this is a duplicate bug of 338554 how come it hasn't been fixed since
> 2006?????

because whether a bug is fixed or not depends on the severity of the issue and finding developers willing to work on the issue and believe me, this is nowhere near the oldest unfixed bug on file. There is no point in maintaining two bug reports for the same issue.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 338554
You need to log in before you can comment on or make changes to this bug.