Location bar appears empty if certain Unicode in URL

RESOLVED DUPLICATE of bug 453827

Status

()

Firefox
Address Bar
--
major
RESOLVED DUPLICATE of bug 453827
9 years ago
8 years ago

People

(Reporter: Corrie Sloot, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [sg:dupe 453827], URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10

The location bar appears empty if a URL contains certain Unicode characters which have a higher line-height than other characters.  The URL is still in the location bar, and can be highlighted, but is pushed down, below the visible area.

This also occurs in pop-up windows, essentially hiding the true page the user is on.  This could be used in phishing schemes.

Reproducible: Always

Steps to Reproduce:
1. Enter URL with special characters in URL, eg. %E2%9F%B5
2. Hit enter

Actual Results:  
Location bar does not show URL.

Expected Results:  
Location bar should always show URL.

Firefox should either not allow such characters in the location bar, or display them differently.
Why the heck does "long leftward arrow" need such extreme height in windows fonts? The glyph itself is pretty short.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Whiteboard: [sg:dupe 453827]
Duplicate of bug: 453827
Group: core-security
You need to log in before you can comment on or make changes to this bug.