Closed Bug 495224 Opened 14 years ago Closed 14 years ago

Builds involving symlinks in the source dir fail to find config/config.mk

Categories

(Firefox Build System :: General, defect)

defect
Not set
minor

Tracking

(status1.9.1 .2-fixed)

RESOLVED FIXED
mozilla1.9.2a1
Tracking Status
status1.9.1 --- .2-fixed

People

(Reporter: mossop, Assigned: mossop)

References

Details

(Keywords: regression)

Attachments

(1 file)

Attached patch patch rev 1Splinter Review
I build a XUL app by symlinking its directory into the mozilla source tree, then building with --enable-application=<dir>. On 1.9.0 this worked, on 1.9.1 it fails with the following error:

gmake[6]: *** No rule to make target `../../../config/config.mk', needed by `_xpidlgen/mccoy.xpt'.  Stop.

A bisect shows bug 467050 as being the culprit. $DEPTH appears to be relative to the real source dir, so it ends up going somewhere else random on my machine to find config.mk. Neil's suggestion that topsrcdir would be better seems to work for me.
Attachment #380116 - Flags: review?(ted.mielczarek)
Comment on attachment 380116 [details] [diff] [review]
patch rev 1

There's actually never a $(DEPTH)/config/config.mk AFAIK, since that'd be in the objdir. I think this is just a bug that slipped by me.
Attachment #380116 - Flags: review?(ted.mielczarek) → review+
(In reply to comment #1)
> (From update of attachment 380116 [details] [diff] [review])
> There's actually never a $(DEPTH)/config/config.mk AFAIK, since that'd be in
> the objdir. I think this is just a bug that slipped by me.

...sorry, good catch.
Pushed: http://hg.mozilla.org/mozilla-central/rev/c4e00b34bbdd
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Assignee: nobody → dtownsend
Target Milestone: --- → mozilla1.9.2a1
Comment on attachment 380116 [details] [diff] [review]
patch rev 1

Would like to take this minor correction fix on branch. It doesn't really affect the Firefox build so there should be no breakage from it.
Attachment #380116 - Flags: approval1.9.1.1?
Comment on attachment 380116 [details] [diff] [review]
patch rev 1

Approved for 1.9.1.2. a=ss for release-drivers

Please land on mozilla-1.9.1 and use the ".2-fixed" option of the "status1.9.1" flag.
Attachment #380116 - Flags: approval1.9.1.1? → approval1.9.1.2+
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.