Subscribers counter for collections shows incorrect value

RESOLVED WONTFIX

Status

addons.mozilla.org Graveyard
Public Pages
--
major
RESOLVED WONTFIX
9 years ago
2 years ago

People

(Reporter: krupa, Assigned: jbalogh)

Tracking

unspecified
5.0.6
x86
All

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Created attachment 380186 [details]
counter

steps to reproduce:
1.Go To collections Home
2.Look for the collection-"Zaphod's set"
3.Notice the number of subscribers-it says zero
4.Add it to your favorites.refresh the page
5.Notice the number of subscribers
6.Remove the collection from your favorites
7.repeat step# 5.

expected result:
subscriber counter shows correct value based on how many people have added the collection to their favorites

actual result:
Even though I added "Zaphod's set" to my favorites and was subscribed to the collection,the counter remained at zero.Its more than 24 hrs since..and it hasnt updated yet.
-> jbalogh since you're working on the subscriber stuff right now
Assignee: nobody → jbalogh
Jeff: Was this caused by 494499 which hadn't landed yet?
(Assignee)

Comment 3

9 years ago
No, that doesn't update subscribers.  The counts should be updated immediately in Collection->subscribe/unsubscribe since they both call _updateSubscribersCount.  I chalked this up to caching when I was it on the collections pages.
(Assignee)

Comment 4

9 years ago
All the code looks correct, so I'm guessing this is a caching issue.  It's always caching.  I was even seeing different subscriber counts for the same collection on listing and detail pages.
How do we confirm it's a caching issue?
(Assignee)

Comment 6

9 years ago
Turning off caching locally and seeing the counts update as they should.
(In reply to comment #6)
> Turning off caching locally and seeing the counts update as they should.

I assigned this to Jeff because Krupa said it had been 24 hours.  If that part is sorted out and this works without caching then this bug is fixed.  We're not setup to deal with instant cache updating at this point.
(Assignee)

Comment 8

9 years ago
Especially with bug 496191's triggers in, the subscriber count on the backend should be correct.  Getting that value past all the caching and into krupa's eyes is a different matter.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.