Closed Bug 495303 Opened 11 years ago Closed 10 years ago

can not move tabs in "3.5 beta 4" with quick keys

Categories

(Firefox :: Tabbed Browser, defect, major)

3.5 Branch
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 491178

People

(Reporter: solproductions, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4 (.NET CLR 3.5.30729)

"Ctrl + Left arrow" or "Ctrl + Right arrow" doesn't move tabs on vista linux or xp. Also, right and left arrows use to scroll through tabs... NO MORE! I would like to see the Up and Down arrows move the page up or down instead of scroll through tabs like it did in earlier versions. Please fix!!!  

Reproducible: Always

Steps to Reproduce:
1.open firefox 3.5 beta 4 
2.when tabs are present slow double click on a tab  
3.with left and right arrow keys, try to scroll... not happening 
4.Use Ctrl+left or right arrows, this should move the tab location... not happining 
Actual Results:  
nothing

Expected Results:  
Left and right arrow keys should scroll through tabs bringing each one into view. Ctrl+left or right arrows, this should move the tab location.



I would like to see the "Up and Down arrows" moving the page up and down when the tab has been selected. 

When closing a tab with Ctrl + W it should automatically select the next tab. This then should allow the user to scroll with arrows left or right through tabs or up down through the page.
Summary: CAN NOT MOVE TABS IN "3.5 beta 4" with quick keys → can not move tabs in "3.5 beta 4" with quick keys
Version: unspecified → 3.5 Branch
Reporter, is this a dupe of Bug 491178 ?
(In reply to comment #1)
> Reporter, is this a dupe of Bug 491178 ?

(In reply to comment #1)
> Reporter, is this a dupe of Bug 491178 ?

Similar but different.  

Ctr+Tab works, yes. But that's additional keys and restrictive you must only go to the right not to the left. Once the tab was selected, It was always just Left + right arrows to navigate through tabs or ctrl+Left or right to move the tabs. This was very easy and convenient. 

This is on the list of Mozilla quick keys.

In addition I would like to see the up and down keys scroll the page up and down, when tab is selected. This something that was never the case. In the past up and down scrolled through the tabs like the left and right arrows keys. 

This then would allow users to scroll with arrows left or right through
tabs or up down through the page.
I see the original bug with Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2a1pre) Gecko/20090528 Minefield/3.6a1pre (.NET CLR 3.5.30729) ID:20090528043233. Looks almost exactly like Bug 491178,
going ahead and duping it for now.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 491178
You need to log in before you can comment on or make changes to this bug.