Enable checking of treehydra in gcc 4.5

RESOLVED FIXED

Status

Firefox Build System
Source Code Analysis
RESOLVED FIXED
9 years ago
5 months ago

People

(Reporter: Brad Hards, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.10) Gecko/2009042708 Fedora/3.0.10-1.fc9 Firefox/3.0.10
Build Identifier: 

make check_both fails on all the treehydra checks when using gcc 4.5

Here is an example:
Test Failure:
    Test command: /home/bradh/devel/gcc-build/gcc/cc1plus -quiet -O1 -ftest-coverage -fplugin=../gcc_treehydra.so -o /dev/null -fplugin-arg-gcc_dehydra-=test_locks_bad4.js locks_bad4.cc
    Failure msg: Expected 'locks_bad4.cc:13: error: precondition not met' in error output; not found. stderr:cc1plus: error: Plugin gcc_dehydra should be specified before -fplugin-arg-gcc_dehydra-=test_locks_bad4.js in the command line
cc1plus: error: Fail to initialize plugin ../gcc_treehydra.so

The problem is that the -fplugin-arg doesn't provide the right plugin type.

Reproducible: Always
(Reporter)

Comment 1

9 years ago
Created attachment 380399 [details] [diff] [review]
patch to address make check problem.
Attachment #380399 - Flags: review?(tglek)
(Reporter)

Updated

9 years ago
Blocks: 484865

Comment 2

9 years ago
Comment on attachment 380399 [details] [diff] [review]
patch to address make check problem.

I'd rather not make another configuration file. I think using some makefile cleverness to pass whether PLUGINS_MOZ flag is set is cleaner.
Attachment #380399 - Flags: review?(tglek) → review-
(Reporter)

Comment 3

9 years ago
Created attachment 380584 [details] [diff] [review]
alternative approach to addressing the problem

Taras,

I've had a think about your suggestions, and while it would be possible to pass both the dehydra and treehydra format command lines as arguments to unit_test_harness.py, that will make for long lines, and would be a bit messy. In addition, it will get uglier if we want to add a third (or fourth, etc) type of test.

Instead, I've allowed the test harness to figure out which type of command line it should use, based on the configure script output (config.mk).
Attachment #380399 - Attachment is obsolete: true
Attachment #380584 - Flags: review?(tglek)

Comment 4

9 years ago
Awesomeness!
pushed
http://hg.mozilla.org/users/tglek_mozilla.com/dehydra-gcc/rev/24bd1cad2e6c

and then i realized that I forgot to test on 4.3, so 
http://hg.mozilla.org/users/tglek_mozilla.com/dehydra-gcc/rev/cbf8795c425a was needed too
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Comment 5

9 years ago
Comment on attachment 380584 [details] [diff] [review]
alternative approach to addressing the problem

stale r+
Attachment #380584 - Flags: review?(tglek) → review+

Updated

5 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.