If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Refactor test cases to check enough runs

RESOLVED FIXED

Status

()

Core
Rewriting and Analysis
--
trivial
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Brad Hards, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.10) Gecko/2009042708 Fedora/3.0.10-1.fc9 Firefox/3.0.10
Build Identifier: 

We have a lot of code in the input_end() functions that looks like:
  if (r.testsRun != 1) {
    print("Error: must be 1 tests run, instead ran " + r.testsRun);
  } else {
    r.list();
  }

It would be nice to factor that out.

Reproducible: Always
(Reporter)

Updated

8 years ago
Blocks: 484865
(Reporter)

Comment 1

8 years ago
Created attachment 380403 [details] [diff] [review]
refactoring of duplicated code

Also throws in a few newlines on the end of files that missed them.
Attachment #380403 - Flags: review?(tglek)

Updated

8 years ago
Attachment #380403 - Flags: review?(tglek) → review?(dmandelin)
Attachment #380403 - Flags: review?(dmandelin) → review+
Comment on attachment 380403 [details] [diff] [review]
refactoring of duplicated code

Good idea.

Comment 3

8 years ago
http://hg.mozilla.org/users/tglek_mozilla.com/dehydra-gcc/rev/54fabccc5a49
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.