tab strip loses + button when you have 4 tabs and fennec is in full screen mode

VERIFIED FIXED

Status

VERIFIED FIXED
10 years ago
9 years ago

People

(Reporter: jmaher, Assigned: mfinkle)

Tracking

Trunk
ARM
Maemo

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
on the N810 there are two modes: regular and full screen.

When adding tabs, you can add 4 tabs for a given tab strip.  There is always a + button at the bottom of the tab strip.  When you have 4 tabs and go to add another, the + button is not visible when you are in regular mode.  switching to full screen shows the button.
Madhava, want to just switch to 3 tabs per column? and keep the nice big thumbnails
always or just in small mode?  I think we mean to open full screen by default in the future, btw.
(Reporter)

Comment 3

10 years ago
I am fine with adjusting to 3 for non full screen.  But it is very easy for the user to switch in/out of full screen mode, so we don't want to remove functionality when they toggle.
tracking-fennec: --- → ?

Updated

10 years ago
Assignee: nobody → gavin.sharp
tracking-fennec: ? → 1.0b3+
Duplicate of this bug: 500502
The + Tabbutton is cut off even in full screen mode, so I think adjusting it to 3 for both modes is going to be necessary to resolve:fixed this bug.
Created attachment 395364 [details] [diff] [review]
patch (fixes full screen)

This patch uses the 2/3 aspect ratio of the n810 to change the size of the thumbnails to 64px x 106px - which is enough to see the 4 tabs and the "+" button in fullscreen.
Attachment #395364 - Flags: review?(gavin.sharp)

Updated

10 years ago
Attachment #395364 - Flags: review?(gavin.sharp) → review+
pushed: https://hg.mozilla.org/mobile-browser/rev/ea3086b832fd

this only fixes the fullscreen case. filing a followup bug to handle the general case.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Summary: tab strip loses + button when you have 4 tabs and fennec is not in full screen mode → tab strip loses + button when you have 4 tabs and fennec is in full screen mode
Assignee: gavin.sharp → mark.finkle
verified FIXED On build:

Mozilla/5.0 (X11; U; Linux armv6l; en-US; rv:1.9.2a2pre) Gecko/20090921
Fennec/1.0b4pre
Status: RESOLVED → VERIFIED
Component: Linux/Maemo → General
QA Contact: maemo-linux → general
You need to log in before you can comment on or make changes to this bug.