patch-3.2 on bugzilla 3.2.3 fails on editproducts.cgi

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
9 years ago
7 years ago

People

(Reporter: bugzilla, Assigned: gregaryh)

Tracking

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 2.0.50727; .NET CLR 3.0.04506.648; .NET CLR 3.5.21022; InfoPath.2)
Build Identifier: 

I installed bugzilla 3.2.3 and am happily running it since a week.
Today I tried to add testopia 2.2 but the patch (patch-3.2) doesn't apply cleanly.
I tried to apply manually the failed patch hunk by editing editproducts.cgi but it doesn't help..
So I went on and installed the missing perl packages until checksetup.pl happy.

I also tried not to apply the patch and installed the missing perl packages until checksetup.pl happy.

For both above scenario, I still got errors when trying to access testopia pages from bugzilla pages.
The last scenario gives me the following error in the web page:
Bareword "ERROR_MODE_AJAX" not allowed while "strict subs" in use at /var/www/bugzilla/tr_list_runs.cgi line 55.
Bareword "ERROR_MODE_AJAX" not allowed while "strict subs" in use at /var/www/bugzilla/tr_list_runs.cgi line 87.
Bareword "ERROR_MODE_AJAX" not allowed while "strict subs" in use at /var/www/bugzilla/tr_list_runs.cgi line 173.
Execution of /var/www/bugzilla/tr_list_runs.cgi aborted due to compilation errors.



Reproducible: Always

Steps to Reproduce:
[bugzilla@markov ~]$ cd /var/www/bugzilla-3.2.3
[bugzilla@markov bugzilla-3.2.3]$ tar xvzf testopia-2.2-BUGZILLA-3.2.tar.gz
[bugzilla@markov bugzilla-3.2.3]$ patch -p0 -i testopia/patch-3.2

Actual Results:  
[bugzilla@markov bugzilla-3.2.3]$ patch -p0 -i testopia/patch-3.2
patching file Bugzilla/WebService/User.pm
patching file Bugzilla/Constants.pm
Hunk #2 succeeded at 374 (offset 3 lines).
patching file Bugzilla/Bug.pm
patching file Bugzilla/Error.pm
patching file Bugzilla/User.pm
patching file editproducts.cgi
Hunk #1 FAILED at 370.
1 out of 1 hunk FAILED -- saving rejects to file editproducts.cgi.rej
patching file Bugzilla/DB/Mysql.pm
Hunk #1 succeeded at 698 (offset 8 lines).
patching file Bugzilla/Install/Filesystem.pm
patching file template/en/default/admin/products/confirm-delete.html.tmpl
Hunk #1 succeeded at 257 with fuzz 2 (offset 2 lines).
patching file template/en/default/global/setting-descs.none.tmpl

Expected Results:  
apply cleanly the patch

please do ask me for any extra information you may need.
Thank you.
Robi

Comment 1

7 years ago
Bugzilla 3.2 is now unsupported. All the development is focused on supported versions (3.6 and above).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.