Lose my logged-in state on Facebook when logging again in PB

RESOLVED INVALID

Status

()

--
major
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: aakashd, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [3.5testday], URL)

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
This happens on the latest nightly on Shiretoko and Trunk:

Build ID: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1pre) Gecko/20090529 Shiretoko/3.5pre ID:20090529033917

and

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090528 Minefield/3.6a1pre ID:20090528112613

Steps to Reproduce
1. Log-in to facebook.
2. Start Private Browsing
3. Go to facebook and log-in again.
4. Stop Private Browsing

Actual Results:
Facebook will return a log-in page (i.e. I was logged out) instead of the home page.

Expected Results:
I should still be logged in when out of private browsing.
(Reporter)

Updated

10 years ago
Whiteboard: [3.5testday]
Using  Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1pre) Gecko/20090529 Shiretoko/3.5pre, I was not able to reproduce this with Facebook. I logged in while a regular browsing session, went to PB and when I came back I was still logged in.

However, over the last day or so I think I have seen instances where I was logged into a site, went into PB and when I came back I was logged out.

Comment 2

10 years ago
(In reply to comment #0)
> 1. Log-in to facebook.
> 2. Start Private Browsing
> 3. Go to facebook and log-in again.
> 4. Stop Private Browsing

Can you please report a full list of your facebook cookies before step 2 and after step 4?

Does step 3 matter, or do you get the same behavior regardless of logging in again on Facebook inside the PB mode or not?

Is the same problem reproducible with other websites which use cookie-based login systems?
(Reporter)

Comment 3

10 years ago
I just used a new profile and was able to re-confirm on the same trunk build Id in the reporter comment.

Comment 4

10 years ago
Could you please test the things I asked about in comment 2, as they're crucial to figure out what the problem is.  Thanks!
(Reporter)

Comment 5

10 years ago
Created attachment 380476 [details]
Before step 2 screenshot

Images of the set of cookies before step 2 and after step 4 have been attached. Also, step 3 is necessary for this bug state to occur. If I don't log-in to facebook while in private browsing mode and then go out, facebook logs me back into the site.

I'm not sure about your last question as I'm not sure what other sites use a similar cookie-based login system right now. Do you have any suggestions?
(Reporter)

Comment 6

10 years ago
Created attachment 380477 [details]
After step 4 screenshot

Comment 7

10 years ago
(In reply to comment #5)
> Created an attachment (id=380476) [details]
> Before step 2 screenshot
> 
> Images of the set of cookies before step 2 and after step 4 have been attached.
> Also, step 3 is necessary for this bug state to occur. If I don't log-in to
> facebook while in private browsing mode and then go out, facebook logs me back
> into the site.

OK, the cookie lists seem very similar.  This might be from Facebook's side (i.e., they might log off the first session as soon as the other session is logged in.)  To test this, you need to open two instances of Firefox, #1 and #2:

1. Log in to facebook in #1.
2. Log in to facebook in #2.
3. Test to see if you're still logged in facebook on #1.

> I'm not sure about your last question as I'm not sure what other sites use a
> similar cookie-based login system right now. Do you have any suggestions?

Gmail, bugzilla, yahoo mail, etc.
(Reporter)

Comment 8

10 years ago
After that test, I'm logged out of facebook in browser #1. 

As for bugzilla, yahoo mail and gmail, they all are logged in before going in and after going out of private browsing using the same reproduction scenario as the reporting comment.

Comment 9

10 years ago
Thanks for testing this.

Based on the observations in comment 8, this seems to be a measure implemented by Facebook, and we don't have any control over it.  Resolving as INVALID.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.