file save as or file save target and like RMB save stores only HTML file

VERIFIED INVALID

Status

Thunderbird
Message Reader UI
--
major
VERIFIED INVALID
9 years ago
8 years ago

People

(Reporter: Martin H. Eastburn, Unassigned)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2010-05-01, URL)

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10
Build Identifier: version 2.0.0.21 (20090302)  Thunderbird and Firefox 3.0.10

I get an email with a file attached that is a CAD file.  I do a "save as" and you
save file_name.pcm.htm the pcm is a CAD file type.  There are many.  I do the same
on web pages - in Yahoo groups and other normal HTML pages. A RMB should preserve the file type and ask (as programmed) and save it as it is.  IF someone ???? police ????? needs to do a RMB on a web page to save it - then the page is the target.  When it is a file link or an attachment - use those attributes.
I can provide email samples and web site samples if needed for unit testing.

Reproducible: Always

Steps to Reproduce:
1.place cursor on the target file to be saved
2.RMB menu to save as (several tokens are used) between FireFox and Thunderbird.
3.use an edit tool - text edit the saved file.  If it is html is is obvious. CAD can be both source code and binary.  It won't have WWW3 or such within.
Actual Results:  
I saved a file : scott cut 3 a.pcm    One file name. It saved to my \temp - 
(win box but was a X7/Unix engineer). the file name saved looked like this:
scott cut 3 a.pcm.htm   I renamed the file and used (RMB) open with Wordpad.
It was a CAD file that had an .htm appended to the file extension.

Expected Results:  
always save as filename.extension   as the native file was.  If there was not a file - e.g. saving a page save it as an htm file extension - but the filename is already defined already.

I do a 'save as' to .pdf, .exe, .gif, jpg, tiff, txt, doc, tcw, zip, xls, ncd
and many others.  These are not html flies nor should they be saved as with that extension.   

I think someone is in a box and isn't looking outside.

Comment 1

9 years ago
Your description is confusing.
If you are using File | save as.. you are trying to save the entire email.
There you have a few choices, one of which is saving as an html file.

If you are right-clicking on an attachment, the file should be saved with the original file extension. There may be some cases where potentially malicious file types might be blocked as in .exe files.

If you can provide an example of a message as an eml file that would help.

Incidentally, the only reference for .pcm files that I can find are not CAD files, but sound files.
Reporter can you reply to comment #1?
Whiteboard: closeme-2009-08-10

Updated

9 years ago
Whiteboard: closeme-2009-08-10 → closeme 2009-08-10
(Reporter)

Comment 3

9 years ago
THIS IS NOT - read that NOT a File(GUI menu) or (Cntl-F) save as but by 
selecting the file in the mail or the pointer to the file - pointer means hyperlink of some sort - and then do a MOUSE RIGHT MOUSE BUTTON  RMB (in unit testing we used RMB, LMB CMB etc).   The right brings up a menu of what to do.
Selecting the save as menu element in the popup GUI - and the file saves.
It saves in a HTML format but the target file is of another file type.

This is not trying to save a page.  Most of my mail is text not hyperlinked
as in colors and graphics.  The CAD group uses links to files they saved
at Yahoo or other sites. The extension is .pcm   that isn't www anything.

Martin

This is a live bug.  The changes in both tools lately have been odd and without thought so it would seem.
Component: General → Mail Window Front End
QA Contact: general → front-end
Whiteboard: closeme 2009-08-10
Version: unspecified → 2.0

Comment 4

8 years ago
please test v3 current version and if working, close with resolution set to WORKSFORME. if it still exists please comment in the bug and attach a screen shot. thanks.
Component: Mail Window Front End → Message Reader UI
QA Contact: front-end → message-reader
Whiteboard: closeme 2010-05-01
RESOLVED INCOMPLETE due to lack of response to previous comment. If you feel this change was made in error, please respond to this bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 6

8 years ago
Created attachment 443940 [details]
This is the cad file captured within a pdf for you & web site

I downloaded the latest version - Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.9) Gecko/20100317 Thunderbird/3.0.4

Now a new tool to get used to :-)  I'm 62 former software and hardware UNIT TEST and Sr. Scientist in the valley.  email the hyperlink to yourself. 
 
This email message is a notification to let you know that
a file has been uploaded to the Files area of the Plasmapig
group.

File : /lionslair_menu/NRA_140_FS_Ram_1.pcm
Uploaded by : lionslair357 <lionslair@consolidated.net>
Description : BB Ram for a test case please ignore

You can access this file at the URL:
http://groups.yahoo.com/group/Plasmapig/files/lionslair_menu   /NRA_140_FS_Ram_1.pcm  <<< this hyperlink  

The pdf of the cad file attached.    - when you get this hyperlink in your email - 
then do a RMB - right mouse button - select "save link as"  
save it to a test directory or desktop.  it will have a .pcm extension as it should, but is a www3 web page.  Use a text editor and open the .pcm file - 
wordpad or Emacs if you use it.  The CAD file will look like this in text:
1.01  and a bunch of control characters...
The version 3+ Thunderbird yields the following (as you will get)
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
<html>
<head>
(Reporter)

Comment 7

8 years ago
Notice the hyperlink wrapped!!!
the filename is NRA_140......pcm    Plasma Cam Machine or cad for a 
PlasmaCam machine.
Status: RESOLVED → VERIFIED
Resolution: INCOMPLETE → INVALID
(Reporter)

Comment 8

8 years ago
Created attachment 443941 [details]
This is the saveas file - note .pcm extsion but www3 file.

Here is the file that is saved to disk - a .pcm file - however this is for 
Version 3 Thunderbird and is actually a saved web page.

What I seem to detect is Thunderbird doesn't ask for user-name and password
if asked - it might be - and since it acts ignorant of the need - it gets the 
web page not a .pcm cad file.

Only a debugger can track and trap various real time debug facts.

Martin
You need to log in before you can comment on or make changes to this bug.