Layout problem(s) for blocks + fonts + floated-table

VERIFIED DUPLICATE of bug 991

Status

()

P3
normal
VERIFIED DUPLICATE of bug 991
20 years ago
19 years ago

People

(Reporter: 3jrgm, Assigned: buster)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

20 years ago
This one is curious. I picked this up at www.boston.com on the front
page when I was checking some other bugs (other (different) bugs on
www.boston.com bug #1431, bug #1240, bug #1239, bug #4836(FIXED)).

 In the present state of this test case, the text "BRIAN MCGRORY"
overlays the IMG (as it did when I saw it on the page www.boston.com
April 9th)

 Tested with April 9 & 10,  win95 opt builds.

 At first, I figured this would come down to one condition. However, there
appear (to me) to be a number of dependencies among the block elements,
the font markup and the floated table. You can (refer to numbers below):

  (1) delete this line and make everything work
  (2) delete this line and the IMG 'disappears'
  (3) delete this line and the IMG 'disappears', but in a different way
  (4) delete this line and make everything work
  (5) drop the align=left, and, (of course) make everything work
  (6) replace the IMG with text, and have the text do the overlay
  (7) lose the <FONT></FONT> tags from around the name, and make everything work
  (8) uncomment this closing </FONT> and make 'Mooney's grass ...' overlay the
      IMG too
------------------------------------------------------------------------
<html><body>

<font face=arial,helvetica size=-1>       <!-- (1) -->
<p>                                       <!-- (2) -->
<br clear=all>                            <!-- (3) -->
<p>                                       <!-- (4) -->

 <table width=50 border=0 align=left>     <!-- (5) -->
  <tr><td>                                <!-- (6) -->
    <img src="http://graphics.boston.com/globe/images/columns/mcgrory.gif"
         width=50 height=62>
  </td></tr>
 </table>
                                          <!-- (7) -->
<font size=-2 color=maroon>BRIAN MCGRORY</font><br>

  Mooney's grass is always greener ... As the Sox return Tuesday for ...
<!-- </font> -->                          <!-- (8) -->

</body></html>
(Reporter)

Comment 1

20 years ago
Created attachment 10 [details]
the test case that I listed above

Updated

20 years ago
Assignee: troy → kipp

Updated

20 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 2

20 years ago
I just tried this with the M4 release (win95 opt) and the test case lays out
fine. All of the variants also lay out fine except one (7). By accident, I
changed the line for (7) above to the one noted below and got the text
'Mooney ..' overrunning the image.


<!--
this is the same HTML as before with one change (7B) remove the
<FONT> from the previous case and 'Mooney's grass ...' overlays
the image.
-->
<html><body>
<font face=arial,helvetica size=-1>
<p>
<br clear=all>
<p>
 <table width=50 border=0 align=left>
  <tr><td>
    <img src="http://graphics.boston.com/globe/images/columns/mcgrory.gif"
         width=50 height=62>
  </td></tr>
 </table>
BRIAN MCGRORY</font><br>                 <!-- (7B) -->
  Mooney's grass is always greener ... As the Sox return Tuesday for ...
</body></html>
(Reporter)

Comment 3

20 years ago
Created attachment 36 [details]
test case; modified slightly from previously
(Reporter)

Comment 4

20 years ago
Original problems resolved. Still demonstrates some problems with <FONT>
wrapped around blocks -- possible dup of bug #991 -- Ian?
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → DUPLICATE
I'm marking this a dup of bug 991. All the pages and test cases on this bug
will be added to 991, so if 991 does not fix them then they are not lost.


*** This bug has been marked as a duplicate of 991 ***

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 6

20 years ago
Agreed. This is a duplicate of 991.
You need to log in before you can comment on or make changes to this bug.