If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

bookmark toolbar bug when right clicking on page

RESOLVED WORKSFORME

Status

()

Firefox
Menus
RESOLVED WORKSFORME
8 years ago
3 years ago

People

(Reporter: diablos_blizzard, Unassigned)

Tracking

3.0 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 (.NET CLR 3.5.30729)

If I right click, and hold, on a page then hover my mouse over to the bookmark toolbar then let go of the right click it shows menus for the website, bookmark toolbar, spelling suggestions and more.

Reproducible: Sometimes

Steps to Reproduce:
1. Right click, don't release, on this current page.
2. Hover over to the bookmark toolbar.
3. Release the right click, and get all of the menus for everything.
Actual Results:  
I get menus for everything.

Expected Results:  
Not sure, perhaps just the menu for the bookmark toolbar
Confirmed with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1pre) Gecko/20090604 Shiretoko/3.5pre (.NET CLR 3.5.30729) ID:20090604045218

Marco, is it a bookmarks and history bug or more a menu one? At least I cannot find another filed bug on that but I'm sure there should be at least one.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → 3.0 Branch
there is one bug about this, that i can't find, even if that had more complex steps. Actually with provided steps i don't see all context menu options but only options for the current page.
I can't tell if it's due to our code or menu code off-hand.
Marco, see my little screencast: http://screencast.com/t/R6Eld9kzlOr

Why we don't open the context menu on mouse down like we do on all other platforms? Neil, can you help us in answering this question?
Hi Henrik,

i just test this old bug-report and saw that you work on it.
after some testing i can't reproduce the problem with actual firefox 34 on Win7

so from my site it is a WFM.
can you confirm this from your system? or do you still have a problem?
Flags: needinfo?(hskupin)
No-one is actually working on it. I just commented on this bug a long time ago. But I had a look and indeed it seems to be fixed. Thank you for checking this bug Stefan! I will close as WFM.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
Flags: needinfo?(hskupin)
You need to log in before you can comment on or make changes to this bug.