Multiple compile errors with cairo-qpainter-surface in Qt port: starting with _cairo_traps_extract_region()

RESOLVED DUPLICATE of bug 493726

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 493726
9 years ago
9 years ago

People

(Reporter: Robert Kaiser, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
/mnt/mozilla/hg/comm-central-trunk/mozilla/gfx/cairo/cairo/src/cairo-qpainter-surface.cpp: In function 'cairo_int_status_t _cairo_qpainter_surface_intersect_clip_path(void*, cairo_path_fixed_t*, cairo_fill_rule_t, double, cairo_antialias_t)':
/mnt/mozilla/hg/comm-central-trunk/mozilla/gfx/cairo/cairo/src/cairo-qpainter-surface.cpp:753: error: cannot convert 'cairo_region_t*' to 'cairo_region_t**' for argument '2' to 'cairo_int_status_t _cairo_traps_extract_region(const cairo_traps_t*, cairo_region_t**)'
/mnt/mozilla/hg/comm-central-trunk/mozilla/gfx/cairo/cairo/src/cairo-qpainter-surface.cpp:784: error: '_cairo_region_num_boxes' was not declared in this scope
/mnt/mozilla/hg/comm-central-trunk/mozilla/gfx/cairo/cairo/src/cairo-qpainter-surface.cpp:787: error: 'cairo_box_int_t' was not declared in this scope
/mnt/mozilla/hg/comm-central-trunk/mozilla/gfx/cairo/cairo/src/cairo-qpainter-surface.cpp:787: error: expected ';' before 'box'
/mnt/mozilla/hg/comm-central-trunk/mozilla/gfx/cairo/cairo/src/cairo-qpainter-surface.cpp:788: error: '_cairo_region_get_box' was not declared in this scope
/mnt/mozilla/hg/comm-central-trunk/mozilla/gfx/cairo/cairo/src/cairo-qpainter-surface.cpp: In function 'cairo_int_status_t _cairo_qpainter_surface_show_glyphs(void*, cairo_operator_t, const cairo_pattern_t*, cairo_glyph_t*, int, cairo_scaled_font_t*, int*, cairo_rectangle_int_t*)':
/mnt/mozilla/hg/comm-central-trunk/mozilla/gfx/cairo/cairo/src/cairo-qpainter-surface.cpp:1409: error: '_cairo_region_init_rect' was not declared in this scope
/mnt/mozilla/hg/comm-central-trunk/mozilla/gfx/cairo/cairo/src/cairo-qpainter-surface.cpp: In function 'void _cairo_image_surface_write_to_ppm(cairo_image_surface_t*, const char*)':
/mnt/mozilla/hg/comm-central-trunk/mozilla/gfx/cairo/cairo/src/cairo-qpainter-surface.cpp:1836: warning: deprecated conversion from string constant to 'char*'
/mnt/mozilla/hg/comm-central-trunk/mozilla/gfx/cairo/cairo/src/cairo-qpainter-surface.cpp:1838: warning: deprecated conversion from string constant to 'char*'
/mnt/mozilla/hg/comm-central-trunk/mozilla/gfx/cairo/cairo/src/cairo-qpainter-surface.cpp: At global scope:
/mnt/mozilla/hg/comm-central-trunk/mozilla/gfx/cairo/cairo/src/cairo-qpainter-surface.cpp:131: warning: 'g_dump_path' defined but not used
/mnt/mozilla/hg/comm-central-trunk/mozilla/gfx/cairo/cairo/src/cairo-qpainter-surface.cpp:132: warning: 'timer_start_val' defined but not used
/mnt/mozilla/hg/comm-central-trunk/mozilla/gfx/cairo/cairo/src/cairo-qpainter-surface.cpp:157: warning: 'const char* _opstr(cairo_operator_t)' defined but not used
gmake[7]: *** [cairo-qpainter-surface.o] Error 1
gmake[7]: Leaving directory `/mnt/mozilla/build/seamonkey-qt/mozilla/gfx/cairo/cairo/src'


Before that, there's a hell lot of warnings from gcc 4.4 about cairoint.h redeclaring things that have been declared in cairo.h already, bzut those are the actual errors. This is with mozilla-central from today and --enable-default-toolkit=cairo-qt (naturally).
(Reporter)

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 493726
You need to log in before you can comment on or make changes to this bug.