All users were logged out of Bugzilla on October 13th, 2018

Problems with import of downloads.rdf after switch to toolkit download manager

RESOLVED DUPLICATE of bug 495680

Status

RESOLVED DUPLICATE of bug 495680
10 years ago
10 years ago

People

(Reporter: bugzilla.spam2, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1pre) Gecko/20090531 SeaMonkey/2.0b1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1pre) Gecko/20090531 SeaMonkey/2.0b1pre

New bug as described in https://bugzilla.mozilla.org/show_bug.cgi?id=381157#c89

Reproducible: Always

Steps to Reproduce:
1. if already exists delete downloads.sqlite
2. start a download
3. in download manager dialog choose "save file"
Actual Results:  
After selecting "save file" it takes quite a long time until windows file selector opens (Probably in this time downloads.rdf is converted to downloads.sqlite - downloads.rdf file size is about 340K).
For every entry in downloads.rdf the error message "x:\...\file.zip could not be saved, because an unknown error occurred. Try saving to a different location." is displayed.
In error console there are several "Error: too much recursion" shown.
After clicking through all error messages the download manager window opens showing the file progress as finished/failed/canceled. 
But no file is really downloaded. 
The partition with the download directory would have enough space to save the files.

Expected Results:  
Import of downloads.rdf happens without error messages.

I tried to strip down downloads.rdf to reproduce the error with a smaller file. But unfortunately the error occurs only with the original file. Because a lot of private urls in the file I can't attach it to this bug. I will try to create a downloads.rdf that triggers this bug the next days.
(Reporter)

Comment 1

10 years ago
Sorry for the bug spam, but bugzilla had a problem when I submitted bug 495680 :-(
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 495680
You need to log in before you can comment on or make changes to this bug.