add or improve title of tests in webshell/tests/viewer/samples

RESOLVED WORKSFORME

Status

Core Graveyard
Tracking
P3
trivial
RESOLVED WORKSFORME
18 years ago
2 years ago

People

(Reporter: Andreas J. Koenig, Assigned: rpotts (gone))

Tracking

Trunk
Future
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
BUILD: today's CVS

It's sometimes hard to keep in mind which test was crashing. Especially as
several tests have the same title and other have no title at all. Introducing a
title to all tests definitely helps.

I used these two perl oneliners to add a title to all tests (run from within the
samples directory):

# add empty title:
perl -0777 -i -pe 'next if /<title/i;s!(<head\s*?>)!$1\n<title></title>!gim;'
*.html

# improve title with filename:
perl -0777 -i -pe 's!(<title>)(.*?</title>)!$1$ARGV: $2!im;' *.html

I'll attach the resulting diff in case you like a diff more than a program.

BTW: The reason why I'd like to see this patch in is because running all tests
more than once leads to a crash with current build. I'd like to reduce the time
needed to reproduce the crash reliably.
(Reporter)

Comment 1

18 years ago
Created attachment 13173 [details] [diff] [review]
Add a title where there is none, add filename to title
(Reporter)

Comment 2

18 years ago
AS a followup to my remark about current crashes: the crashes apparently can not
be reproduced with the tests. I had something broken in my ~/.mozilla/
directory. Removing the whole directory helped. I still need to find out what it
was, but it seems "it" is not related to the tests.

Comment 3

18 years ago
rick, who can fix this?
QA Contact: leger → rickg

Comment 4

18 years ago
reproter: has this been improved?
(Reporter)

Comment 5

18 years ago
Nothing has changed. For the record, the files are in
webshell/tests/viewer/samples/. The 4 most recent files there have a timestamp
of Sept 14, all others are older than my report.

Comment 6

18 years ago
Marking as NEW as per reporters comments.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

17 years ago
Status: NEW → ASSIGNED

Comment 7

17 years ago
rpotts?
Assignee: chofmann → rpotts
Status: ASSIGNED → NEW

Updated

17 years ago
Target Milestone: --- → Future
Go go gadget passage-of-time: they're all dead now.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.