Closed Bug 495699 Opened 11 years ago Closed 11 years ago

TM: Assertion failure: original == thisv - js1_5/Regress/regress-462989.js - browser only

Categories

(Core :: JavaScript Engine, defect)

x86
All
defect
Not set
normal

Tracking

()

VERIFIED FIXED

People

(Reporter: bc, Assigned: gal)

References

Details

(4 keywords, Whiteboard: fixed-in-tracemonkey)

Attachments

(1 file)

tracemonkey && mozilla-central so far.

Assertion failure: original == thisv, at /work/mozilla/builds/1.9.1-tracemonkey/mozilla/js/src/jstracer.cpp:6737

js1_5/Regress/regress-462989.js

http://test.bclary.com/tests/mozilla.org/js/js-test-driver-standards.html?test=js1_5%2FRegress%2Fregress-462989.js;language=type;text/javascript


js1_5/Regress/regress-463782.js

http://test.bclary.com/tests/mozilla.org/js/js-test-driver-standards.html?test=js1_5%2FRegress%2Fregress-463782.js;language=type;text/javascript

looking for the regressor now.
Flags: in-testsuite+
this made it onto mozilla-1.9.1 as well.
Flags: blocking1.9.1?
Assignee: general → gal
I can't reproduce either assert with TM tip. Maybe the hotfix is missing? Does your test build include:

http://hg.mozilla.org/releases/mozilla-1.9.1/rev/e5fe9c68d8d3

?
It should have. I bisected from tracemonkey tip and I reproduced with a fresh tracemonkey build before doing the bisection. Note this is browser only.
confirmed assert on 1.9.1, 1.9.1 tracemonkey, 1.9.2 browser on mac with fresh builds on both test cases.
I bet TM asserts should block, but maybe this regression test isn't something we need to worry about? Wishful thinking? :)
Flags: blocking1.9.1? → blocking1.9.1+
Attached patch patchSplinter Review
I hate wrappers. And inner and outer object.
Attachment #380937 - Flags: review?(mrbkap)
Attachment #380937 - Flags: review?(mrbkap) → review+
Keywords: checkin-needed
http://hg.mozilla.org/tracemonkey/rev/f5e7ed3980ee
Whiteboard: fixed-in-tracemonkey
http://hg.mozilla.org/mozilla-central/rev/f5e7ed3980ee
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Keywords: checkin-needed
v 1.9.1, 1.9.2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.