Provide automatic feedback via email for add-ons pending editor review

RESOLVED WONTFIX

Status

addons.mozilla.org Graveyard
Developer Pages
--
enhancement
RESOLVED WONTFIX
9 years ago
2 years ago

People

(Reporter: Dave Garrett, Unassigned)

Tracking

({ue})

Details

(Reporter)

Description

9 years ago
I have an extension that's been pending editor review for public status for well over 4 weeks now. While I know that there's always quite a few extensions that are pending review and it takes time, the wait itself could be handled better. (the wait really gone up these days) I'd like to have an automatic once a week email sent out with a brief status update to let me know that I am in fact not forgotten, preferably with an approximate count for the queue "ahead" of me and any other useful info. An email should also be sent on initial submission to acknowledge that things were queued successfully in the first place.

This won't make anything run faster, but it would resist a little of the frustration of those waiting. ;)
Since the queue isn't FIFO-enforced approximating count is really hard and if it ever goes up between emails will look like idiots. ;)

I'm not sure what other "useful info" we'd stick in there either.  Anyway, CCing rbango as this is in his court.
(Reporter)

Comment 2

9 years ago
(In reply to comment #1)
> Since the queue isn't FIFO-enforced approximating count is really hard and if
> it ever goes up between emails will look like idiots. ;)

Yeah, it'd have to be intentionally inaccurate to a fair degree, but anything is better than nothing. What would really be best is to give a guess on the remaining wait time but that may be even harder.

Another idea might be to have a histogram view of the queue with your position in it labeled. (see bug 342931) Could just add this to the developer control panel and link to it from the email so people could also check it whenever they want.
I think an e-mail a week is too bothersome, but I like the spirit of the bug. At the very least, I hope this reduces the number of e-mails on the mailing list relating to the issue, which is always answered the same way.

Maybe instead of an email, we can have a page in the developer control panel that shows how long the add-on has been in the queue, followed by some other statistics such as the length of queue, median and average age of the queue, and the age of the longest add-on spent in the queue. And to make things even more depressing, we can show how many add-ons were reviewed (and rejected) vs. how many new add-ons went into the queue for the week.

While I don't think the numbers will be very encouraging, I think knowing a realistically reasonable time is better than having the feeling of being forgotten as the weeks drag into months for some authors.

Comment 4

9 years ago
@Dave: I think exposing more information about the queue is a great idea. I prefer Cesar's idea as it's less intrusive than the weekly email. I'm going to give this some thought to see how we can make this happen in some fashion that provides a measure of realistic data to authors.
I think this is either a wontfix or a dupe of bug 435273 then.  There is also another (I think still open) bug that got us the public stats on https://addons.mozilla.org/en-US/statistics

Comment 6

9 years ago
(In reply to comment #5)
> I think this is either a wontfix or a dupe of bug 435273 then.  There is also
> another (I think still open) bug that got us the public stats on
> https://addons.mozilla.org/en-US/statistics

Looks to me like that link should provide good info. I would say that it's a messaging issue at this point and agree that this should be a wontfix.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.