All users were logged out of Bugzilla on October 13th, 2018

Personas do not appear on latest Thunderbird builds for OpenSolaris

RESOLVED FIXED

Status

RESOLVED FIXED
10 years ago
2 years ago

People

(Reporter: stevegca, Assigned: cbeard)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4
Build Identifier: Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.9.1b4pre) Gecko/20090329 Lightning/1.0pre Shredder/3.0b3pre 

Personas installs just fine under nightly builds of Thunderbird (Shredder) for OpenSolaris.  Attempting to display any of them, however, just results in font colors changing with each skin (no image is displayed).

I am using the default theme in Thunderbird and do have this working on Windows.  It just doesn't appear to work in OpenSolaris.

Reproducible: Always

Steps to Reproduce:
1. Get nightly build of Thunderbird (Shredder) for OpenSolaris on x86
2. Install Personas
3. Try changing skins
Actual Results:  
Font colors change, but the background images never appear.

Expected Results:  
Font colors change plus a new background image appears when a different Persona is selected.

Looking at the build ID, it looks like Gecko is fairly old in this build.  Not sure if that's the culprit, or if it's something else.
(Reporter)

Comment 1

10 years ago
My bad on the build ID.  I was fiddling to see if there was another version I could test on before I submitted this.  The correct build for TB/Shredder I am using is:

Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.9.1b5pre) Gecko/20090520 Lightning/1.0pre Shredder/3.0b3pre
(Reporter)

Updated

10 years ago
OS: Other → OpenSolaris

Comment 2

10 years ago
Confirm with Thunderbird 3.0 nightly (http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/contrib/latest-comm-1.9.1/) on OpenSolaris 2009.06: Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.9.1b5pre) Gecko/20090520 Shredder/3.0b3pre.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

10 years ago
Created attachment 381014 [details] [diff] [review]
patch for OpenSolaris

The patch gives a similar fix as bug 488650 did for Firefox. It works for me on OpenSolaris.
Attachment #381014 - Flags: review?(myk)

Comment 4

10 years ago
Jeff, maybe you're also interested in verifying this on FreeBSD with Thunderbird 3.0?
Attachment #381014 - Flags: review?(myk) → review+
Comment on attachment 381014 [details] [diff] [review]
patch for OpenSolaris

Ah, indeed. r=myk
I've committed this along with the equivalent fix for FreeBSD in changeset http://hg.mozilla.org/labs/personas/rev/2bed70efcdff.  I've also pushed a dev build with the changes <http://people.mozilla.com/~cbeard/personas/dist/personas-dev.xpi>.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

10 years ago
The dev build mentioned in comment #6 does the trick for me on OpenSolaris.  Nicely done!
Product: Mozilla Labs → Mozilla Labs Graveyard
You need to log in before you can comment on or make changes to this bug.