Click on Evernote and Firefox crashes and everything is gone and I have to re-open everything.

VERIFIED FIXED

Status

()

Toolkit
Blocklisting
VERIFIED FIXED
9 years ago
2 years ago

People

(Reporter: Rev. Bernie Siebers, Assigned: Andrew McGeachie)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.0.11) Gecko/2009051908 Firefox/3.0.11
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.0.11) Gecko/2009051908 Firefox/3.0.11

I added Everynotes from a suggestion of Firefox and it worked well for a long time,  Just recently when I click on to add something the site rashes. I quit using it because of that.   Rev. Bernie 

Reproducible: Always

Steps to Reproduce:
1. I just find something that I would like to put into evernotes to save and probably E-mail.
2. I this make sure I am on the right page. 
3.Click on the evernote icon and  " CRASH " 



I can't add too much. I love Firefox except for this recent glitch.   I am using a beta version of Firefox, I believe. Rev. Bern.

Updated

9 years ago
Component: Private Browsing → General
Keywords: crash
QA Contact: private.browsing → general
Version: unspecified → 3.0 Branch
I confirmed this on Firefox 3.0.10 and the nightly 1.9.0 build for last night.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

9 years ago
Signature	___TERMINATING_DUE_TO_UNCAUGHT_EXCEPTION___
UUID	71430386-9342-452b-a6bc-ed9032090601
Time 	2009-06-01 21:55:07.448610
Uptime	68
Last Crash	447058 seconds before submission
Product	Firefox
Version	3.0.10
Build ID	2009042315
Branch	1.9
OS	Mac OS X
OS Version	10.5.7 9J61
CPU	x86
CPU Info	GenuineIntel family 6 model 7 stepping 6
Crash Reason	EXC_BREAKPOINT / EXC_I386_BPT
Crash Address	0x94638f54
User Comments	https://bugzilla.mozilla.org/show_bug.cgi?id=495784
Processor Notes 	
Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	CoreFoundation 	___TERMINATING_DUE_TO_UNCAUGHT_EXCEPTION___ 	
1 	libobjc.A.dylib 	libobjc.A.dylib@0x9e3a 	
2 	ENMacMozillaClipper.dylib 	ENMacMozillaClipper.dylib@0x26e6 	
3 	ENMacMozillaClipper.dylib 	ENMacMozillaClipper.dylib@0x275d 	
4 	ENMacMozillaClipper.dylib 	ENMacMozillaClipper.dylib@0x7082 	
5 	Foundation 	-[NSThread main] 	
6 	Foundation 	__NSThread__main__ 	
7 	libSystem.B.dylib 	_pthread_start 	
8 	libSystem.B.dylib 	thread_start 	

filename: /Users/timeless/Library/Caches/TemporaryItems/evernote-mac-clips/clip-tmp/firefox-clip.html
url: http://en-us.www.mozilla.com/en-US/firefox/3.0.10/whatsnew/
encoding: 
title: Firefox Updated
An uncaught exception was raised
Could not find the Evernote application via NSWorkspace
*** Terminating app due to uncaught exception 'AppNotFoundException', reason: 'Could not find the Evernote application via NSWorkspace'
Stack: (\n    2489553067,\n    2505416251,\n    26804932,\n    26805097,\n    26805745,\n    26806110,\n    26824835,\n    2499505677,\n    2499504564,\n    2510471509,\n    2510471186\n)
347 firefox-bin[1235:10b] filename: /Users/timeless/Library/Caches/TemporaryItems/evernote-mac-clips/clip-tmp/firefox-clip.html
349 firefox-bin[1235:10b] url: http://en-us.www.mozilla.com/en-US/firefox/3.0.10/whatsnew/
349 firefox-bin[1235:10b] encoding: 
349 firefox-bin[1235:10b] title: Firefox Updated
351 firefox-bin[1235:5a33] An uncaught exception was raised
351 firefox-bin[1235:5a33] Could not find the Evernote application via NSWorkspace
352 firefox-bin[1235:5a33] *** Terminating app due to uncaught exception 'AppNotFoundException', reason: 'Could not find the Evernote application via NSWorkspace'
Component: General → Extension Compatibility
QA Contact: general → extension.compatibility

Comment 3

9 years ago
Firefox 3.0.10 doesn't crash if i install Evernote and have it running.... Nor does it crash if i quit Evernote, in which case it launches Evernote.

Reporter: you should be able to run Console.app to find out why Evernote is unhappy.

AMO Admins: please tell Evernote that they're being Blocklisted for crashing our product in an expected error case. It's ok to give the user an error message, it isn't ok to crash the browser.
Component: Extension Compatibility → Blocklisting
Product: Firefox → addons.mozilla.org
QA Contact: extension.compatibility → blocklisting
Version: 3.0 Branch → unspecified

Comment 4

9 years ago
@timeless: Evernote has 6 public versions. Which version do you plan on blocklisting?

Comment 5

9 years ago
I've contacted Evernote and asked them to reference this bug report for details. I'm waiting for feedback from them.
(In reply to comment #3)
> AMO Admins: please tell Evernote that they're being Blocklisted for crashing
> our product in an expected error case. It's ok to give the user an error
> message, it isn't ok to crash the browser.

We, uh, don't normally just blocklist an extension because it crashes. It'd have to be a pretty prevalent crash. If we can get Evernote to fix this, that'd be best. Note that the crash only happens if you don't have Evernote installed (Al had to app-zap it).

Comment 7

9 years ago
Sam, I received email from them telling me that they're looking into it. From the email:

"Yes, from the link you sent. Our developers should be able to track it down pretty quickly."

Comment 8

9 years ago
I just emailed them asking them to update this bug with information & to be proactive in replying here so that we know that the crashes are being addressed.

Comment 9

9 years ago
Thanks for the report. We are looking into this bug.

-Alex
Evernote

Comment 10

9 years ago
I don't really want to block things. But if things plug into our product and cause crashes, we need to prod people into fixing them. This isn't about rare hard to reproduce crashes, it's about basic crashes.

Alex: thanks. I'm assigning this to you so that I can easily see the contact for your extension.

Rey: for completeness, I have Evernote Web Clipper 3.0.0.46749

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.10) Gecko/2009042315 Firefox/3.0.10

As this crash is OS X only, a hypothetical block would be limited to OS X. Based on my reading of the versions, it would only apply to:
Version 3.0.0.45382 
Version 3.0.0.46749
and the current one.

Anyway, I'm hoping they'll fix it w/in a week. I believe the simplest fix is probably one try block, and falling back to the web ui (which afaiu exists as code for the Linux version). Eventually the web ui could remind the user that they are using it because Evernote.app isn't installed and offer a link to download it.

In terms of timeline, if things don't get fixed w/in 3 (or 6) months, then I'd suggest we actually roll out a block. But, my hope is to remind extension authors that we're serious and that fixing bugs is important, and that they'll fix them :).
Assignee: nobody → alex+ffbugz
(Assignee)

Comment 11

9 years ago
Hi folks.  I'm the Mac tech lead @ Evernote.  Thanks for tracking this.  We're working on a fix for this now and hope to have an updated extension ready in a day or two.

timeless: You are exactly correct, an exception was being thrown in Objective-C code and percolating all the way up to Firefox. :(

Updated

9 years ago
Assignee: alex+ffbugz → geechorama
(Assignee)

Comment 12

9 years ago
OK, we've got a new build ready for our QA dept.  We'll keep you posted.
(Assignee)

Comment 13

9 years ago
3.0.0.50288 fixes this bug has been posted.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
I installed that and, if I have no Evernote installed on OS X, it still crashes instead of opening up the web-based clipper.

http://crash-stats.mozilla.com/report/index/a361b633-3334-40b3-9944-fcde92090604?p=1

I installed 3.0.0.50288 in a clean Firefox profile for this.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 15

9 years ago
darn it.
(Assignee)

Comment 16

9 years ago
OK I'm able to reproduce this.  Will try to get a new build out within the next week.
(Assignee)

Comment 17

9 years ago
New build submitted to Evernote QA.
(Assignee)

Comment 18

9 years ago
3.0.0.51093 is live.
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
This looks to fix things. I don't get a crash anymore when the web clipper comes up.
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → Toolkit
You need to log in before you can comment on or make changes to this bug.