Status

mozilla.org Graveyard
Server Operations
--
minor
RESOLVED INVALID
9 years ago
3 years ago

People

(Reporter: sgarrity, Assigned: aravind)

Tracking

Details

(Reporter)

Description

9 years ago
I'm sure the right people are painfully aware, but svn updates and status commands are very slow. Full updates can sometimes take several minutes.

Thought I'd file a bug in case it's fixable.

Comment 1

9 years ago
Are you talking about the mozilla.com repo? The slowness might be on your side:
svn info
Path: .
URL: http://svn.mozilla.org/projects/mozilla.com/tags/production
Repository Root: http://svn.mozilla.org
Repository UUID: 4eb1ac78-321c-0410-a911-ec516a8615a5
Revision: 26825
Node Kind: directory
Schedule: normal
Last Changed Author: jslater@mozilla.com
Last Changed Rev: 26820
Last Changed Date: 2009-06-01 14:11:53 -0700 (Mon, 01 Jun 2009)

time svn status > /dev/null

real	0m3.087s
user	0m0.540s
sys	0m0.958s

Seems reasonable considering there are 20,000 files (125,000 including .svn) in that repo.
(Reporter)

Comment 2

9 years ago
After about 12 hours since the last update, I'm seeing this: 

$ svn info
Path: .
URL: https://svn.mozilla.org/projects/mozilla.com/trunk
Repository Root: https://svn.mozilla.org
Repository UUID: 4eb1ac78-321c-0410-a911-ec516a8615a5
Revision: 26870
Node Kind: directory
Schedule: normal
Last Changed Author: rq@akl.lt
Last Changed Rev: 26870
Last Changed Date: 2009-06-02 06:38:25 -0300 (Tue, 02 Jun 2009)


$ time svn update > /dev/null

real	6m30.173s
user	0m2.411s
sys	0m6.508s


After that update is run after, subsequent updates are much quicker.
(Assignee)

Updated

9 years ago
Assignee: server-ops → aravind
(Assignee)

Comment 3

9 years ago
This appears like the problem is on your end. The first time you did it, it was slow probably because your laptop had to fetch a ton of things from your hard drive.  The second time, they are all in cache, so its faster.

Regular checkouts and checkins seem fine to me.  Please re-open with more information if you think this is a problem on the server side.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.