Status

Calendar
General
--
minor
VERIFIED INVALID
9 years ago
9 years ago

People

(Reporter: Lupatrian, Unassigned)

Tracking

Sunbird 0.9
x86
Linux

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.10) Gecko/2009042523 Ubuntu/9.04 (jaunty) Firefox/3.0.10
Build Identifier: 2.0.0.21, and Provider for G-cal 0.5.1

I don't know if this is a bug, given that task-sync isn't integrated [yet], but here's my issue: In the TBird calendar > my Google Cal (using Provider for G-cal ext), if I R-click an event and request Convert to Task (either from the calendar view or from the event list), nothing happens; event does not become a task. 

I tested, and it does work for Convert to Message. I know the tasks won't show up in my on-line Google task list, but it should work within TBird, right? 

Thanks. 

Reproducible: Always

Steps to Reproduce:
1. R-click an event
2. Convert > To Task
3.
Actual Results:  
Nothing changes at all.

Expected Results:  
Addition of item to TBird task list. 

Workaround would be to create task manually.
(Reporter)

Updated

9 years ago
Component: Address Book → General
Version: unspecified → 2.0
Component: General → General
Product: Thunderbird → Calendar
QA Contact: address-book → general
Version: 2.0 → Sunbird 0.9
(Reporter)

Comment 1

9 years ago
Update: 
File > New, Task is greyed-out (so no work-around). 

I did some further testing: disabled Provider ext: that's not the issue.

Issue is this: Tasks will not work at all if the only calendar you are using is
a Google Cal (because no integrated tasks). I added a local Test cal and
Tasks/Convert-to-Task resumed working. So, is that a bug?
Component: General → Provider: GData
QA Contact: general → gdata-provider

Comment 2

9 years ago
If there's no calendar to put tasks in, Lightning prevents you from creatnig erronous tasks. So this is working as expected.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Component: Provider: GData → General
QA Contact: gdata-provider → general
Resolution: --- → INVALID
Lupatrian, have a look at bug 493389 which is the relevant enhancement request if you are interested.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

9 years ago
Thank you Martin, and Bas. (And apologies for wasting time with a non-bug.)
You need to log in before you can comment on or make changes to this bug.