Lightning notification bar appears at the bottom of the message pane.

RESOLVED FIXED in 1.0b1

Status

defect
RESOLVED FIXED
10 years ago
8 years ago

People

(Reporter: standard8, Assigned: martinschroeder)

Tracking

(Blocks 1 bug, {regression})

Dependency tree / graph

Details

Attachments

(3 attachments)

Reporter

Description

10 years ago
Posted image The problem
Bug 454829 changed the structure of the message pane to include an extra vbox. This means the notification bar now appears at the bottom of the message pane because its not hooking in the right place. See attached screenshot.
Flags: blocking-calendar1.0?
Posted patch Patch v1Splinter Review
Assignee: nobody → mschroeder
Status: NEW → ASSIGNED
Attachment #380931 - Flags: review?(bugzilla)
Sounds like Lightning will not work correctly in Thunderbird 3.0 Beta 2 after the patch anymore. Drop support for it and raise required Thunderbird version to 3.0b3pre?
Reporter

Comment 3

10 years ago
Comment on attachment 380931 [details] [diff] [review]
Patch v1

r=me by inspection.

I agree with Stefan's comment that you should update the min thunderbird version as well - without that, loading latest lightning into builds before TB changed will place the notification bar at the bottom.
Attachment #380931 - Flags: review?(bugzilla) → review+
Thanks for the heads-up. I adjusted the minVersion as suggested.

Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/8f47b438d34b>

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Flags: blocking-calendar1.0?
Resolution: --- → FIXED
Target Milestone: --- → 1.0

Comment 5

10 years ago
<vbox id="singlemessage" insertbefore="msgHeaderView"> should allow the lightning bar to work in builds  before 3.0b3pre as well as after.
This is not fixed for the standalone message window because the <vbox id="singlemessage" flex="1"> is missing (messageWindow.xul).

Mark, is it sensible to ask for an alignment of the messagepanebox in messenger.xul and messageWindow.xul, so we can easily overlay both with the same piece of xul?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Makes sense to me.  I'm happy to whip up a patch if mark thinks it's ok.
Reporter

Comment 8

10 years ago
(In reply to comment #6)
> This is not fixed for the standalone message window because the <vbox
> id="singlemessage" flex="1"> is missing (messageWindow.xul).
> 
> Mark, is it sensible to ask for an alignment of the messagepanebox in
> messenger.xul and messageWindow.xul, so we can easily overlay both with the
> same piece of xul?

I can't see that being a problem, it makes sense to keep them similar for extensions.
I should have tried Philip's suggestion from comment#5 before my last comment... this is also the solution for my problem in comment#6. But i think it's okay to leave the minVersion at 3.0b3pre, right?
Attachment #381404 - Flags: review?(bugzilla)
Attachment #381404 - Attachment is patch: true
Attachment #381404 - Attachment mime type: application/octet-stream → text/plain
If the solution works in both Thunderbird 3.0b2 and 3.0b3pre I'd reset the min version down to 3.0b2 to not loose feedback from the Lightning nightly testers using 3.0b2 until 3.0b3 is released.
Reporter

Comment 11

10 years ago
Comment on attachment 381404 [details] [diff] [review]
Fix for overlaying messageWindow.xul

Looks good, r=Standard8.

Allowing 3.0b2 again could be a good idea as we haven't released b3 yet. Though if you start using some of the new tab features on other bugs, then you may find you're broken against b2 again, but I suspect that could be a few weeks off.
Attachment #381404 - Flags: review?(bugzilla) → review+
I reset the minVersion to b2 as suggested. 

Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/096acd1ed9b2>

-> FIXED
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → FIXED
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.