Clear private data does not fully clear browsing history

RESOLVED DUPLICATE of bug 493151

Status

()

RESOLVED DUPLICATE of bug 493151
10 years ago
9 years ago

People

(Reporter: mcepl, Unassigned)

Tracking

3.5 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; cs-CZ; rv:1.9.1b4) Gecko/20090427 Fedora/3.5-0.20.beta4.fc11 Firefox/3.5b4
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; cs-CZ; rv:1.9.1b4) Gecko/20090427 Fedora/3.5-0.20.beta4.fc11 Firefox/3.5b4

(originally filed as https://bugzilla.redhat.com/show_bug.cgi?id=502320)

Tools->Clear private data doesn't actually delete the browsing history
completely when the Browsing Data checkbox is ticked

Reproducible: Always

Steps to Reproduce:
1.Clear private data
2.Restart firefox just in case it's needed to clear state
3.Click on location bar, and up pops a list of websites visited.
Actual Results:  
Browsing history not cleared

Expected Results:  
Browsing history cleared
Does the list have a bunch of stars next to them? If so, this is not a bug, as those are bookmarks being displayed. You can choose what to display via the privacy preference pane in Tolls>Options
Version: unspecified → 3.5 Branch

Comment 2

10 years ago
Dupe of bug 496561.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 493151

Comment 4

9 years ago
(In reply to comment #3)
> 
> *** This bug has been marked as a duplicate of bug 493151 ***

Why?  Bug 496561 is *identical* (except for the 'originally filed' line).  There has clearly been an accidental double-post, and as bug 496561 has a lot more discussion this one should be resolved as a duplicate of that.  

If you want to resolve bug 496561 as a dupe of bug 493151 then fine, but that is the wrong resolution for this bug.
You need to log in before you can comment on or make changes to this bug.