jQuery originated exceptions when calling 'click event on jQuery objects

RESOLVED DUPLICATE of bug 543533

Status

Mozilla Labs
Jetpack Prototype
P3
normal
RESOLVED DUPLICATE of bug 543533
9 years ago
8 years ago

People

(Reporter: jfk k, Unassigned)

Tracking

unspecified
x86
Windows Vista

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10
Build Identifier: 0.1.5

This is my jetpack addon for easing R apidS hare pains... http://pastebin.com/f5ecc3a49

Everything works as intended. The only thing that bugs me is that on error console, strange exceptions originating in jQuery code pop up. The funny thing? My Jetpack addon works nonetheless :)

Example: Error: [Exception... "Component returned failure code: 0x80540006 [nsIStreamListener.onDataAvailable]"  nsresult: "0x80540006 (<unknown>)"  location: "JS frame :: file:///D:/Documents/Profiles/Mozilla-Firefox/FF.3.5b4/extensions/firebug@software.joehewitt.com/components/firebug-channel-listener.js :: anonymous :: line 107"  data: no]
Source File: file:///D:/Documents/Profiles/Mozilla-Firefox/FF.3.5b4/extensions/firebug@software.joehewitt.com/components/firebug-channel-listener.js
Line: 107

How to get rid of the exception? See diff http://pastebin.com/pastebin.php?diff=m15ff1aab



Reproducible: Always

Steps to Reproduce:
1. run addon http://pastebin.com/f5ecc3a49
2. go to r apids hare to download a file
3. addon will click 'free user', than will wait for 'save' button and will click it
4. during pt 3 on error console you will see exceptions, this will not disturb addon
Actual Results:  
exception like this:

Example: Error: [Exception... "Component returned failure code: 0x80540006 [nsIStreamListener.onDataAvailable]"  nsresult: "0x80540006 (<unknown>)"  location: "JS frame :: file:///D:/Documents/Profiles/Mozilla-Firefox/FF.3.5b4/extensions/firebug@software.joehewitt.com/components/firebug-channel-listener.js :: anonymous :: line 107"  data: no]
Source File: file:///D:/Documents/Profiles/Mozilla-Firefox/FF.3.5b4/extensions/firebug@software.joehewitt.com/components/firebug-channel-listener.js
Line: 107

Expected Results:  
no exceptions

Updated

9 years ago
Priority: -- → P3
Target Milestone: -- → 0.5

Updated

9 years ago
Target Milestone: 0.5 → 0.6

Comment 1

9 years ago
This might be due to Firebug incompatibility issues, in which case this bug could depend on bug 506122.

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 543533

Updated

8 years ago
Blocks: 543533
You need to log in before you can comment on or make changes to this bug.