Last Comment Bug 495985 - Mouse right-click on web page results in various random actions
: Mouse right-click on web page results in various random actions
Status: RESOLVED DUPLICATE of bug 404314
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-02 10:58 PDT by Chris Richards
Modified: 2009-06-02 12:12 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Chris Richards 2009-06-02 10:58:36 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.10) Gecko/2009042708 Fedora/3.0.10-1.fc10 Firefox/3.0.10
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.10) Gecko/2009042708 Fedora/3.0.10-1.fc10 Firefox/3.0.10

Normally, when one right-clicks the mouse on a web page, a context menu will pop up, containing various options depending on the particular item that one right-clicks on.

On occasion, rather than getting the context menu some action will be performed.  This action varies, and only seems to occur when a very rapid right-click is executed (i.e. the right mouse button is pressed and then released in a very short time span).  Executing a right-click more slowly (click taking on the order of 1/2 second or so) seems to reliably bring up the context menu).

I am currently 

Reproducible: Sometimes

Steps to Reproduce:
1.Navigate to web page of interest
2.Highlight some text and right-click on it (e.g. to copy for pasting into another document) or right-click on an image (e.g. to copy the image location).
3.IMPORTANT: Execute the right-click as quickly as possible!
4.Repeat above process, but using a slow mouse right-click (> 500 mS).
Actual Results:  
Observe that at occasionally, completely unexpected things will happen.  This may happen 1 time in 100, or 1 time in 5.

Expected Results:  
The right-click context menu should pop up.
Comment 1 Kevin Brosnan 2009-06-02 11:00:10 PDT
This should be fixed in 3.0.11

*** This bug has been marked as a duplicate of bug 404314 ***
Comment 2 Chris Richards 2009-06-02 12:12:52 PDT
Sorry about the duplicate bug.

I searched.  Honest, I did.  No, really, I did.

Note You need to log in before you can comment on or make changes to this bug.