Front page layout on http://www.corriere.it/ does not show correctly

RESOLVED INVALID

Status

()

RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: marcia, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

Reported via hendrix. Using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1pre) Gecko/20090602 Shiretoko/3.5pre the page in the URL bar does not lay out correctly. The login and registrations buttons do not render correctly and the name of the site is missing.

This occurs using Firefox 3.5 Beta 4 as well. Safari renders the page correctly. Screenshot attached showing the incorrect layout.
Created attachment 381201 [details]
Screenshot of issue using latest 1.9.1 nightly
Created attachment 381202 [details]
Screenshot of site using Safari

Comment 3

9 years ago
Site bug, I'd say (and Safari is kinda wrong...).
Opera (10a) has a near identical problematic display, and IE 8 would have the same issue if it were served the same styles (but on that site IE 8 is in 'IE7 mode'). I'll attach a minimised testcase.

The misplaced title image is caused by the wrapping of the two login items. Those two are in spans with a class 'clearfix', that uses generated content set to display block. That in turn causes the two words to display on separate lines; that pushes the logo image to the right.

This is a change from bug 238072.

Changed between 
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1a2pre) Gecko/20080818032051 Minefield/3.1a2pre

and 
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1a2pre) Gecko/20080817040141 Minefield/3.1a2pre

Comment 4

9 years ago
Created attachment 381223 [details]
minimised from URL

(see comment 3)
Why should there be a line break between "Login" and "Registrati" in attachment 381223 [details]?

Comment 6

9 years ago
(In reply to comment #5)
> Why should there be a line break between "Login" and "Registrati" in attachment
> 381223 [details]?
The .clearfix class applied to each span causes the line break.

.clearfix:after {

	display: block; /* <---------- */

}


Note that at time of writing, the site displays correctly in the latest Minefield build. A quick look at the source, it seems the site changed the markup/styling of the header.
Oh, right... I missed that both spans had class="clearfix"; I only saw it on the second one.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.