No download link for file for other OS with privacy policy or EULA (non-browser only?)

VERIFIED FIXED in 5.0.7

Status

addons.mozilla.org Graveyard
Public Pages
P3
normal
VERIFIED FIXED
9 years ago
2 years ago

People

(Reporter: aryx, Assigned: abuchanan)

Tracking

Details

(URL)

Attachments

(1 attachment)

Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.12pre) Gecko/2009052505 GranParadiso/3.0.12pre

No download link for file for other OS with privacy policy or EULA (non-browser only?)

1. Go to https://addons.mozilla.org/de/thunderbird/addons/versions/8616
2. Click a link for the file of another operating system.

Actual result (for me as Windows user who clicked Linux):
Page https://addons.mozilla.org/de/thunderbird/addons/policy/0/8616/49761 has no download button.
Assignee: nobody → buchanae
Priority: -- → P3
Target Milestone: --- → 5.0.7
(Assignee)

Comment 1

9 years ago
This problem stems from views/elements/amo2009/install.thtml line 378

    if (!$versionsPage) {
        echo "fixPlatformLinks('{$versionId}', '{$addonName}');";
    }


On the versions page, a button for any platform may be displayed (fixPlatformLinks usually hides these other buttons).  The problem is that this is a EULA page, so it isn't caught by this rule.

So, I need to figure out a way to apply this to the EULA page, but only when you're coming from the versions page.

Unless, is there a better suggestion?  I'm not sure yet.

Cheers
(Assignee)

Comment 2

9 years ago
Created attachment 384789 [details] [diff] [review]
patch v1

Afaik, we always link to a EULA page with a file ID specified in the URL, e.g.

/thunderbird/addons/policy/0/8616/49761

which means that a EULA page should only ever show 1 install button.

fixPlatformLinks() is meant to choose one install button from many platform options. Since we only have one file, this patch turns it off for the EULA page.


note:  if you don't include a file ID in the URL, you get a policy page, which has no install buttons
Attachment #384789 - Flags: review?(lorchard)
Comment on attachment 384789 [details] [diff] [review]
patch v1

works for me
Attachment #384789 - Flags: review?(lorchard) → review+
(Assignee)

Comment 4

9 years ago
Sending        app/controllers/addons_controller.php
Sending        app/views/addons/policy.thtml
Sending        app/views/elements/amo2009/install.thtml
Transmitting file data ...
Committed revision 28423.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
verified fixed on https://addons.mozilla.org/de/thunderbird/addons/versions/8616
Status: RESOLVED → VERIFIED
Duplicate of this bug: 502996
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.