If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Video's reported length should be equal to that of current playtime when resuming download/playback of local video file

RESOLVED WORKSFORME

Status

()

Core
Audio/Video: Playback
RESOLVED WORKSFORME
8 years ago
2 years ago

People

(Reporter: aaronmt, Unassigned)

Tracking

1.9.1 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1pre) Gecko/20090603 Shiretoko/3.5pre

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090603 Minefield/3.6a1pre

Noticed two oddities today when starting playback & resuming that of a partial download of a video play (played back in browser)

Steps to reproduce:

1. Go to this URL http://tinyvid.tv/show/2om556hp18ya3 which has a nice big video
2. Open a blank new tab (which to be used for local video)
3. 'Save Video As' & begin to download
4. Pause after a wealthy amount has been downloaded
5. Drag the video into the new tab for it to play locally in the browser

* Notice that the reported end time length is the time of the amount downloaded so far *

6. Resume download and resume playback (hit play again)

Two issues here

Actual results: 

1. When the scrubber reaches the end of the horizontal time frame, the scrubber will not update the remaining time unless you leave the video and re hover over it for the controls and time line to be redrawn (is this by design?).

2. Since the video does not know the final time (as it is being downloaded), should it not be equal to that of the current time (in the scrubber)? 

The issue is that it continues to report the primary download's time, so you end up with something like this

http://i42.tinypic.com/14obwc0.png

Expected results:

1. On a partial and resumed download, the scrubber should reflect the current time in real time without having to re-hover on the timeline/controls

2. The end time should be equal to that of the current time since playback started on a partial download
(Reporter)

Comment 1

8 years ago
#1 in actual results correction

1. When the scrubber reaches the end of the horizontal time frame, the scrubber's current time will not update unless you leave the focused area of the video via mouse. In order to display the update, one must re hover over it for the controls and time line to be redisplay (is this by design?).
(Reporter)

Comment 2

8 years ago
Screencast

http://www.filedropper.com/2009-06-041030
Component: Audio/Video → Audio/Video: Playback
Does this issue still exist?
(Reporter)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.