Firefox crashes and closes without any errors when I choose a file to upload to my album [@ MpegSplitter.ax@0x249eb]

RESOLVED INVALID

Status

()

Firefox
General
--
critical
RESOLVED INVALID
9 years ago
7 years ago

People

(Reporter: Moe, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10

When trying to upload a file to photobucket, firefox crashes, It allows you to log in and select the files you've already uploaded no problem however, when you try to upload a new file from the page and you click on choose file, It opens another window where you would choose the file you want to upload and after 3 seconds of the new window being open firefox crashes. 

Reproducible: Always

Steps to Reproduce:
1. Go to Photobucket.com
2. Enter User name & password and click login
3. When logged in on fist page click Choose Files
4. Screen comes up to choose files and in 3 seconds firefox shuts down
Actual Results:  
Firefox shuts down without any errors or messages. 
Upon start-up again asks if i want to resume last session or start new session.
 

Expected Results:  
At the #4 step firefox should NOT shut down. You should be able to choose the file you want, after you choose the file you click OPEN and on Photobucket.com file should show a percentage of the file being uploaded. 

I have used Photobucket.com with firefox for the past 8+ months without any problems. I don't know why this problem as started.
(Reporter)

Updated

9 years ago
Summary: Photobucket I have uploaded pictures many time from my computer to my albums. now, when I choose a file to upload to my album, Firefox just closes on it's own without any errors or anything → Photobucket I have uploaded pictures many time from my computer to my albums on photobucket.com . now, when I choose a file to upload to my album, Firefox crashes and closes on me on it's own without any errors or anything

Comment 1

9 years ago
https://developer.mozilla.org/En/How_to_get_a_stacktrace_for_a_bug_report
Summary: Photobucket I have uploaded pictures many time from my computer to my albums on photobucket.com . now, when I choose a file to upload to my album, Firefox crashes and closes on me on it's own without any errors or anything → Firefox crashes and closes without any errors when I choose a file to upload to my album
(Reporter)

Comment 2

9 years ago
Here are my Submitted Crash Reports

Report ID                                   Date Submitted

86809985-1c7a-43d9-a333-c17612090603	6/3/2009	5:52 PM
8195cdf2-b238-495d-9e14-505a52090603	6/3/2009	5:48 PM
37229399-2160-4a31-a599-3bffb2090603	6/3/2009	5:47 PM
efc64d9c-4c07-4843-b6f3-4a7d82090603	6/3/2009	5:47 PM
0 MpegSplitter.ax MpegSplitter.ax@0x249eb 

This is external code that is crashing Firefox and it could be from the  K-Lite Codec Pack. based on a google search it's causing all kind of issues/crashes for example in IE7

Please notify the author of that code about the issue
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

9 years ago
So if i uninstall K-Lite Codec Pack....This will FIX the issue correct??

Comment 5

9 years ago
reporter: if you remove the file that's listed as crashing, then yes, after a reboot it should be virtually impossible to crash in exactly the same place.

However, i'd like to get a better stack trace first if you're willing, please follow:
https://developer.mozilla.org/en/How_to_get_a_stacktrace_with_WinDbg

when you crash, in addition to having entered all the commands listed in the instructions, please also enter: "~* kp". then use the "add an attachment" link of this bug to attach the log c:\firefox-debug-(Today's Date).txt to this report (i'm trying to understand what the main thread is doing).

the following is mostly for future reference by developers.
this looks vaguely suspicious: https://trac.xiph.org/ticket/1516

http://codecs.freeforums.org/post1523.html#p1523
seems to be the most relevant reference, i really do need the stack trace I mentioned earlier

> Postby clsid on Sun Dec 16, 2007 1:37 pm 
> The workaround is to disable the Gabest MPEG splitter

> Postby clsid on Sun Apr 13, 2008 10:29 am
> Thanks for the info.
> The problem is partly caused by the buggy thumbnail shell extension of
> Explorer. Crashes can also occur with other DirectShow filters.

I hate doing this research, but it appears that
http://guliverkli.svn.sourceforge.net/viewvc/guliverkli/trunk/guliverkli/src/filters/parser/mpegsplitter/
is probably the origin of this thing, however I can't spot a problem in the latest version.

Signature	MpegSplitter.ax@0x249eb
UUID	86809985-1c7a-43d9-a333-c17612090603
Time 	2009-06-03 17:52:19.668223
Uptime	63
Last Crash	231 seconds before submission
Product	Firefox
Version	3.0.10
Build ID	2009042316
Branch	1.9
OS	Windows NT
OS Version	6.0.6001 Service Pack 1
CPU	x86
CPU Info	AuthenticAMD family 15 model 104 stepping 1
Crash Reason	EXCEPTION_INT_DIVIDE_BY_ZERO
Crash Address	0x7d249eb
User Comments	
Processor Notes 	
Crashing Thread (18)
Frame 	Module 	Signature [Expand] 	Source
0 	MpegSplitter.ax 	MpegSplitter.ax@0x249eb 	

Show/hide other threads
Thread 0
Frame 	Module 	Signature [Expand] 	Source
0 	ntdll.dll 	ntdll.dll@0x59a94 	
1 	user32.dll 	user32.dll@0x20207 	
2 	duser.dll 	duser.dll@0x161d 	
3 	duser.dll 	duser.dll@0x29af 	
4 	duser.dll 	duser.dll@0x294e 	
5 	user32.dll 	user32.dll@0xb0d9 	
6 	ntdll.dll 	ntdll.dll@0x599cd 	
7 	user32.dll 	user32.dll@0xbcd9 	
8 	user32.dll 	user32.dll@0xbd1b 	
9 	user32.dll 	user32.dll@0xbd3f 	
10 	comdlg32.dll 	comdlg32.dll@0x5eac 	
11 	comdlg32.dll 	comdlg32.dll@0x34b23 	
12 	comdlg32.dll 	comdlg32.dll@0x375da 	
13 	comdlg32.dll 	comdlg32.dll@0x37723 	
14 	comdlg32.dll 	comdlg32.dll@0x37797 	
15 	comdlg32.dll 	comdlg32.dll@0x24a9f 	
16 	comdlg32.dll 	comdlg32.dll@0x253e8 	
17 	xul.dll 	nsFilePicker::ShowW 	mozilla/widget/src/windows/nsFilePicker.cpp:265
18 	xul.dll 	nsFilePicker::Show 	mozilla/widget/src/windows/nsFilePicker.cpp:402
19 	xul.dll 	NS_InvokeByIndex_P 	mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp:101
20 	xul.dll 	XPCWrappedNative::CallMethod 	mozilla/js/src/xpconnect/src/xpcwrappednative.cpp:2393


Filename 	Version 	Debug Identifier 	Debug Filename
FLVSplitter.ax 	1.0.0.2 	5F37EA95553740B5859DA59BF9AA42A48 	FLVSplitter.pdb
WavPackDSSplitter.ax 	1.1.0.319 		
ad2mcdsmpeg.ax 	1.0.0.75 		
RealMediaSplitter.ax 	1.0.1.1 	A56A2EEA068C48BF876BF378A7BD33A11 	RealMediaSplitter.pdb
ad2mcac3dec.dll 	1.1.3.0 		
MpegSplitter.ax 	1.0.0.5 	1BD7C966D9E7452C8246AC655EC92FFA3 	MpegSplitter.pdb
MP4Splitter.ax 	1.0.0.3 	CEC14923F7714CD081A3F7D2859D08572 	MP4Splitter.pdb
ulspmp4.ax 	1.0.4.9 		
ad2mpegin.dll 	1.4.0.21595 		
vsfilter.dll 	1.0.1.4 	E594AD05DB0F4EECA0F0AD8E915DEC5A2 	VSFilter.pdb
ad2h264dec.004 	1.4.0.21597 		
ad2h264dec.dll 	1.4.0.21597 		
ad2dsh264.ax 	1.2.0.20511 		
ad2mcspmpeg.ax 	1.0.1.8 		
ad2mcmpgdec.dll 	1.1.1.40 		
WMVCORE.DLL 	11.0.6001.7001 	69270F3106C043939189F6FD181543C12 	wmvcore.pdb
mediametadatahandler.dll 	6.0.6001.18000 	06828C3AD4BF4054A047BB197AF4FDAA1 	MediaMetadataHandler.pdb
msmpeg2adec.dll 	11.0.6001.7000 	55D62E7077A64709955C80BBBFFF5ED62 	msmpeg2adec.warbird.pdb
tiptsf.dll 	6.0.6001.18000 	A558D5F10F9E406787C038A8919AFF552 	tiptsf.pdb
msvfw32.dll 	6.0.6001.18000 	714F6556AB1A45B589F8FAE564DAF03F1 	msvfw32.pdb
dxva2.dll 	6.0.6001.18000 	8E2BE12DD5CC41C3A0037F1B3C603E752 	dxva2.pdb
msshsq.dll 	7.0.6001.16503 	A3EC9712205448619D783D6F81B8862B2 	MSSHSQ.pdb
actxprxy.dll 	6.0.6001.18000 	83EB3E71E13743339D8CBAB04FB4E1A92 	ActXPrxy.pdb
WMASF.DLL 	11.0.6001.7000 	E93720150ED34FB5B3FE74E27B94816C2 	WMASF.pdb
dwmapi.dll 	6.0.6001.18000 	1E6F7E8306934DD8A2953D21A720F52D2 	dwmapi.pdb
mpg2splt.ax 	6.6.6001.18177 	B7D8DB78ADFD43ABBAC4A559CDFAFBC21 	mpg2splt.pdb
WindowsCodecs.dll 	6.0.6001.18131 	0D8EDE1431F94C90B13330C188B803E52 	WindowsCodecs.pdb
AudioEng.dll 	6.0.6001.18000 	FCDA059ED5E3414E85A97D61168D1A682 	AUDIOENG.pdb
midimap.dll 	6.0.6001.18000 	C8620017433446F3B909A7FC82E835B41 	midimap.pdb
msacm32.dll 	6.0.6001.18000 	376918E968B945C7AFADC00C7A541A422 	msacm32.pdb
AudioSes.dll 	6.0.6001.18000 	1EE865A82D3441F1B243F762B90507782 	AudioSes.pdb
msacm32.drv 	6.0.6001.18000 	E22B8CC4E734457EBED7740AFAC6C29F1 	msacm32.pdb
wdmaud.drv 	6.0.6001.18000 	7B6ECBCD46884781922A97258828EBC62 	wdmaud.pdb
ksuser.dll 	6.0.6000.16386 	F4E61857491042318000C5CE88B4D6E62 	ksuser.pdb
winmm.dll 	6.0.6001.18000 	0F510C3C6FA5429CB90B3CAC010DAE2A2 	winmm.pdb
mlang.dll 	6.0.6001.18000 	E50729F123AE48F48236F259AABC01FB2 	mlang.pdb
duser.dll 	6.0.6001.18000 	8753BF70B9E043B78BE5E8616AF70B732 	DUser.pdb
MMDevAPI.dll 	6.0.6001.18000 	971E0FC87AB1469198E292ACC748EEA82 	MMDevAPI.pdb
Keywords: crash
Summary: Firefox crashes and closes without any errors when I choose a file to upload to my album → Firefox crashes and closes without any errors when I choose a file to upload to my album [@ MpegSplitter.ax@0x249eb]
It should be enough if you unregister it to solve the issue with 
"regsvr32 /u mpegsplitter.ax" if you can not find an updated version
(Reporter)

Comment 7

9 years ago
I had removed the program once i read you said it was klite....I just removed it right away and i fixed the problem.....I hope i don't have anymore problems like that in the past...but if i do I know where to go.

Thanks so much for the help. Greatly appreciated.
(Assignee)

Updated

7 years ago
Crash Signature: [@ MpegSplitter.ax@0x249eb]
You need to log in before you can comment on or make changes to this bug.