Hours donated counter is broken

VERIFIED DUPLICATE of bug 496220

Status

Websites Graveyard
mozillaservice.org
VERIFIED DUPLICATE of bug 496220
9 years ago
8 years ago

People

(Reporter: krupa, Unassigned)

Tracking

unspecified
x86
Mac OS X

Details

(Reporter)

Description

9 years ago
steps to reproduce:
1.Log in to your mozservice account
2.pledge 9000 hours.
3.Wait till the counter gets updated.
4.Go back and pledge 1000hrs more
5.Repeat step#3

expected result:
counter shows hours donated=10,000hrs

actual result:
counter shows hours donated=1000hrs

Comment 1

9 years ago
Maybe this is a copy bug?

When you change the box from 9000 to 1000, you are not adding an additional 1000. You are instead saying "reduce my pledge by 8000".

So expected results are domated=1000hrs.

Comment 2

9 years ago
Jane, what are your thoughts?

Comment 3

9 years ago
right - okay that is strange... I think we should be "adding" the pledged hours. Can we / do we want to show what they have already pledged? 


NB: you can also enter a minus number, and decial point numbers -- we probably dont want to have either of these cases be able to be entered.  



also - we probably want to restrict this to a 3 digit field - to minimize really wacky numbers... (on that same note - will it be easy for us to pull any really silly numbers entered e.g. 999 hours then another 999 hours etc... 

FYI - once the numbers are at 6 digits e.g. 100,000 this could screw up the header... (just wanted to flag this so we can make sure it doesnt)

Comment 4

9 years ago
Please see my updated comment on this bug:
https://bugzilla.mozilla.org/show_bug.cgi?id=496220

which also refer to the previously raised issues

Comment 5

9 years ago
If we should always be adding numbers, I think we need to spec this out.

Wouldn't they need to be able to put in a negative number, if they accidentally pledged 10 hours and need to go back and pledge 1 hour. They would put in a -9.

Also, the UI needs more work. Something like
* Hours to Pledge
How many hours do you think will be volunteered for this project?
33 hours pledged change by [] more hours

[] is the input box

The current form is
Hours to Pledge
How many hours do you think will be volunteered for this project?
[10]

This seems to make sense to me. I pledged 10 and meant 1, so I change 10 to 1 and hit Submit.

Maybe we can rename Submit to
First time - Pledge Hours
Returning users - Update Pledge

If we want to drastically change how this works, I need to know ASAP, as it may require backend changes.

Comment 6

9 years ago
Okay, just reading 496220, which seems to fix this.
Depends on: 496220

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 496220
(Reporter)

Comment 8

9 years ago
verified
Status: RESOLVED → VERIFIED

Updated

8 years ago
Component: mozillaservice.org → mozillaservice.org
Product: Websites → Websites Graveyard
You need to log in before you can comment on or make changes to this bug.