Add-on counter corrupted for several locales

VERIFIED FIXED in 5.0.6

Status

addons.mozilla.org Graveyard
Localization
VERIFIED FIXED
9 years ago
2 years ago

People

(Reporter: wladow, Assigned: wenzel)

Tracking

({regression})

unspecified
5.0.6
regression

Details

Attachments

(1 attachment)

Created attachment 381485 [details]
screenshot

Bug 432847 has regressed, there's a corrupted character in AMO download stats on AMO2009 layout main page. Affected locales: at least sk, cs, ru, fi. This should be 5.0.6 release blocker.
(Assignee)

Comment 1

9 years ago
It is a blocker, but also easy to fix.

I just accidentally filed a dupe of this... -- but let me quote myself:

"The download counter code uses number_format() which is multibyte-unaware and
leads to display errors (see attached screenshot).

Luckily, we have an mb-safe number_format function since bug 432847, so we
should use that."
Keywords: regression
(Assignee)

Updated

9 years ago
Duplicate of this bug: 496302
(Assignee)

Comment 3

9 years ago
Fixed: r27086. It should show up on preview in a little while.

Thank you for your help, Vlado!
Assignee: nobody → fwenzel
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Keywords: push-needed
Resolution: --- → FIXED
Verified FIXED on:

https://preview.addons.mozilla.org/sk/firefox/
https://preview.addons.mozilla.org/cs/firefox/
https://preview.addons.mozilla.org/ru/firefox/
https://preview.addons.mozilla.org/fi/firefox/
Status: RESOLVED → VERIFIED
removing "push-needed" from 105 AMO 5.0.6 bugs; filter on "I hate stephend!"
Keywords: push-needed
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.