Drafts are saved to wrong folder with multiple IMAP accounts configured

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: Not interested in Mozilla any more, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.10) Gecko/2009042315 Firefox/3.0.10
Build Identifier: version 2.0.0.21 (20090302)

If you have multiple user accounts on the same IMAP server draft messages that are saved go into the drafts folder on a random account.

Reproducible: Sometimes

Steps to Reproduce:
1. Create a setup with multiple user accounts on the same IMAP server. For example 4 users (user1, user2, user3 and user4)
2. Open and login to all accounts and ensure they are working correctly in Thunderbird
3. Create a new message by clicking the write button.
4. Select one of the IMAP accounts from the 'From' drop down list at the top of the window. (for example user1).
5. Enter a subject and some text in the body of the message.
6. Close the window and select save when asked if you wish to save the message as a draft.
Actual Results:  
The draft is saved into a drafts folder but not always the one you have selected in the 'From' drop down list.

Expected Results:  
You would expect the message to be saved in the drafts folder on the account you had selected in the 'From' drop down on the Compose window.
Drafts(Sent, Templates too) is assigned to each identity(From: mail address used for mail composition), instead of account to which the mail address is related.
Read at least next documents, please. 
> http://kb.mozillazine.org/Mail_concepts#Account_settings
> http://kb.mozillazine.org/Mail_concepts#Identities
> http://kb.mozillazine.org/Multiple_identities_per_e-mail_account

Is your setting correct?
If you share an IMAP account by multiple Tb instances, check identity settings of all Tb instances.
If your problem relates to "Edit of already saved draft mail", check X-Identity-Key: header of the draft mail, and check identity number of each idnetity definition of all Tb instances.
(Reporter)

Comment 2

9 years ago
Yes, I know about that and each is account is setup to store its drafts in it's own drafts folder (as is Sent and Templates etc). That is not the problem. 

This is a brand new email, created by clicking the Write button while clicked on the inbox of one of the accounts. It is then closed and saved to drafts. The problem is it does not always go to the drafts folder of the account you have selected.

I'm happy that once you open an email, from drafts, that saving it again puts it back in the correct drafts folder.

Comment 3

9 years ago
Hi Ian. can you reproduce this using version 3?
(Reporter)

Comment 4

9 years ago
Not with my initial testing. I will continue to look. I will mark resolved for now and re-open if I find an issue later. Seems fixed in:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.7) Gecko/20100111 Thunderbird/3.0.1
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Updated

9 years ago
Resolution: FIXED → WORKSFORME
Version: unspecified → 2.0
You need to log in before you can comment on or make changes to this bug.