Remove tons of JS from search element

VERIFIED DUPLICATE of bug 526576

Status

addons.mozilla.org Graveyard
Search
P3
enhancement
VERIFIED DUPLICATE of bug 526576
9 years ago
2 years ago

People

(Reporter: wenzel, Unassigned)

Tracking

unspecified
4.x (triaged)

Details

(Reporter)

Description

9 years ago
The search element contains a bunch of JS code that should better be in the addons.js file, because:

- the code is sent to the user on almost every page
- it won't be minified or cached for a long time
- it does not belong there
...

While we are at it, we can replace the user agent matching in there by the global user agent detection code I recently wrote at the top of the addons.js file.
Component: Public Pages → Search
(Reporter)

Comment 1

8 years ago
Still there, still as ugly as ever, very realignmentworthy.
Priority: -- → P3
Target Milestone: --- → 4.x (triaged)
(Reporter)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 526576
Verified duplicate.
Status: RESOLVED → VERIFIED
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.