If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Hang when starting a test via command line (jsbridge)

VERIFIED FIXED

Status

Testing Graveyard
Mozmill
P2
critical
VERIFIED FIXED
8 years ago
a year ago

People

(Reporter: whimboo, Assigned: mikeal)

Tracking

Details

(Whiteboard: [verified-mozmill-1.2])

(Reporter)

Description

8 years ago
Today I discovered again that tests hang when they get started from the command line via jsbridge. The browser gets opened but nothing happens. It stucks forever and I have to kill the browser and python process. For the latter one I have the following stack after pressing Ctrl+C:

 File "/usr/local/bin/mozmill-restart", line 8, in <module>
    load_entry_point('mozmill==1.2b1', 'console_scripts', 'mozmill-restart')()
  File "/Volumes/data/build/mozmill/trunk/mozmill/__init__.py", line 388, in restart_cli
    RestartCLI().run()
  File "/Volumes/data/build/mozmill/trunk/mozmill/__init__.py", line 375, in run
    super(RestartCLI, self).run(*args, **kwargs)
  File "/Volumes/data/build/mozmill/trunk/mozmill/__init__.py", line 348, in run
    self.options.report)
  File "/Volumes/data/build/mozmill/trunk/mozmill/__init__.py", line 285, in run_tests
    self.run_dir(d, report, sleeptime)
  File "/Volumes/data/build/mozmill/trunk/mozmill/__init__.py", line 248, in run_dir
    frame = self.start_runner()
  File "/Volumes/data/build/mozmill/trunk/mozmill/__init__.py", line 200, in start_runner
    frame = jsbridge.JSObject(bridge, "Components.utils.import('resource://mozmill/modules/frame.js')")
  File "/Library/Python/2.5/site-packages/jsbridge-2.0b1-py2.5.egg/jsbridge/jsobjects.py", line 76, in __init__
    name = bridge.set(name)['data']
  File "/Library/Python/2.5/site-packages/jsbridge-2.0b1-py2.5.egg/jsbridge/network.py", line 196, in set
    return self.run(_uuid, 'bridge.set('+', '.join([encoder.encode(_uuid), obj_name])+')')
  File "/Library/Python/2.5/site-packages/jsbridge-2.0b1-py2.5.egg/jsbridge/network.py", line 173, in run
    sleep(interval)

Inside Minefield the following errors are shown:

Error: [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIXPCComponents_Utils.import]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: file:///private/var/folders/w2/w2myuXRLE1q1Ex7puQAPYk+++TI/-Tmp-/tmpXo3ZbL.mozrunner/extensions/jsbridge@mozilla.com/resource/modules/server.js :: <TOP_LEVEL> :: line 245"  data: no]
Source File: file:///private/var/folders/w2/w2myuXRLE1q1Ex7puQAPYk+++TI/-Tmp-/tmpXo3ZbL.mozrunner/extensions/jsbridge@mozilla.com/resource/modules/server.js
Line: 245

Error: uncaught exception: 2147746065

Error: uncaught exception: [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIXPCComponents_Utils.import]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: file:///private/var/folders/w2/w2myuXRLE1q1Ex7puQAPYk+++TI/-Tmp-/tmpXo3ZbL.mozrunner/extensions/mozmill@mozilla.com/resource/stdlib/logging.js :: Logger :: line 43"  data: no]

Error: uncaught exception: [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIXPCComponents_Utils.import]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: file:///private/var/folders/w2/w2myuXRLE1q1Ex7puQAPYk+++TI/-Tmp-/tmpXo3ZbL.mozrunner/extensions/mozmill@mozilla.com/resource/modules/controller.js :: <TOP_LEVEL> :: line 42"  data: no]

Error: uncaught exception: [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIXPCComponents_Utils.import]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: file:///private/var/folders/w2/w2myuXRLE1q1Ex7puQAPYk+++TI/-Tmp-/tmpXo3ZbL.mozrunner/extensions/mozmill@mozilla.com/resource/modules/mozmill.js :: <TOP_LEVEL> :: line 48"  data: no]

Error: uncaught exception: [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIXPCComponents_Utils.import]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: file:///private/var/folders/w2/w2myuXRLE1q1Ex7puQAPYk+++TI/-Tmp-/tmpXo3ZbL.mozrunner/extensions/mozmill@mozilla.com/resource/modules/init.js :: <TOP_LEVEL> :: line 41"  data: no]

Error: uncaught exception: [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIXPCComponents_Utils.import]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: chrome://mozmill/content/overlay.js :: <TOP_LEVEL> :: line 40"  data: no]

Same happens with Shiretoko. We already had this topic once on IRC and the problem went away magically. But now it is back. Jsbridge and Mozmill are build from latest trunk.
(Reporter)

Updated

8 years ago
Priority: -- → P2
(Reporter)

Comment 1

8 years ago
Now I even get the following stack from python:
  File "/usr/local/bin/mozmill-restart", line 8, in <module>
    load_entry_point('mozmill==1.2b1', 'console_scripts', 'mozmill-restart')()
  File "/Volumes/data/build/mozmill/trunk/mozmill/__init__.py", line 388, in restart_cli
    RestartCLI().run()
  File "/Volumes/data/build/mozmill/trunk/mozmill/__init__.py", line 375, in run
    super(RestartCLI, self).run(*args, **kwargs)
  File "/Volumes/data/build/mozmill/trunk/mozmill/__init__.py", line 348, in run
    self.options.report)
  File "/Volumes/data/build/mozmill/trunk/mozmill/__init__.py", line 285, in run_tests
    self.run_dir(d, report, sleeptime)
  File "/Volumes/data/build/mozmill/trunk/mozmill/__init__.py", line 248, in run_dir
    frame = self.start_runner()
  File "/Volumes/data/build/mozmill/trunk/mozmill/__init__.py", line 189, in start_runner
    self.runner.start()
  File "build/bdist.macosx-10.5-i386/egg/mozrunner/__init__.py", line 430, in start
  File "build/bdist.macosx-10.5-i386/egg/mozrunner/__init__.py", line 87, in run_command
  File "/System/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/subprocess.py", line 593, in __init__
    errread, errwrite)
  File "/System/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/subprocess.py", line 1079, in _execute_child
    raise child_exception
OSError: [Errno 13] Permission denied
(Reporter)

Comment 2

8 years ago
Mikeal, this is very suspicious. Today it works like a charm. Is it somehow related to new versions of Mozmill/JsBridge and how they get installed? I haven't changed anything. Only did a couple of restarts in-between.
(Assignee)

Comment 3

8 years ago
I spent 3 days fixing issues like this in jsbridge so it's not crazy to think that this issue was fixed in jsbridge trunk.

I ran the multi-restart unittest 30 times, which works out to 150 restarts without issue.
(Reporter)

Comment 4

8 years ago
The last change was on June 2nd with http://code.google.com/p/jsbridge/source/detail?r=114. So nothing has been changed since this day. I haven't installed a new version of jsbridge meanwhile too. So I would blame the installation routine for now. Something seems to be made which requires a restart?

Comment 5

8 years ago
Anthony just repro'd this bug on a normal checkout of mozmill trunk rev 501 and is hitting it when trying to install the extension in the browser.  I also hit this when trying to install the extension a few days ago but it wasn't reproducible.  Trying to reproduce now in a debug build because I can't figure out what is going on otherwise.  This blocks 1.2.
Whiteboard: [mozmill-1.2]
(Assignee)

Comment 6

8 years ago
This was a bug in jsbridge. It's fixed in jsbridge trunk.
(Assignee)

Comment 7

8 years ago
Pushed new jsbridge release, 2.0b2, to PyPI.

easy_install -U jsbridge should fix you all up.
Turns out, these exceptions occur when installing Mozmill in a browser when multiple browsers are running.  This prevents loading of the Mozmill IDE.
(Assignee)

Comment 9

8 years ago
Fixed in trunk. r503 and r504.
(Reporter)

Updated

8 years ago
Blocks: 491216
(Assignee)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Verified fixed in r504.
Status: RESOLVED → VERIFIED
(Reporter)

Updated

8 years ago
Assignee: nobody → mrogers
OS: Mac OS X → All
Hardware: x86 → All
Whiteboard: [mozmill-1.2] → [verified-mozmill-1.2]
Product: Testing → Testing Graveyard
You need to log in before you can comment on or make changes to this bug.