configure fails on Linux Mandrake 7.1

VERIFIED FIXED

Status

SeaMonkey
Build Config
P3
normal
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: Mark Stankus, Assigned: cls)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.73 [en] (X11; I; Linux 2.2.15-4mdk i686)
BuildID:    2000082012

(The build id is irrelevent since I could not build --- I faked it)

./configure failed for Linux Mandrake

Reproducible: Always
Steps to Reproduce:
cvs checkout the source
./configure

Actual Results:  							

Expected Results:  See the added attachment
(Reporter)

Comment 1

18 years ago
Created attachment 13205 [details]
This is a capture of my attempt to configure (+more)

Comment 2

18 years ago
Has this worked for you in the past?  Can we see the output of /sbin/ldconfig -v
and of echo $LD_LIBRARY_PATH?
(Assignee)

Comment 3

18 years ago
Is /usr/X11R6/lib in your /etc/ld.so.conf ?  Can you attach config.log as well?
(Reporter)

Comment 4

18 years ago
Bottom Line: The problem disappeared and so is "fixed".

Extra notes: 
1. echo $LD_LIBRARY_PATH gave an invalid variable
2. I clicked on something in XChat and I had KDE and GNOME
     both running. When I quit GNOME, configure worked again.

Thanks
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 5

18 years ago
verified.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

18 years ago
Created attachment 14353 [details]
a unix 'script' captured script
(Reporter)

Comment 7

18 years ago
Hi,
 
  I want this bug reopened, since it happened to me again.
./configure has worked in the past, but then I messed up my W95
did a clean install and then did a "upgrade" on LinuxMandrake 7.1
from Linux Mandrake 7.1 (to get the boot sector correct). I have
attached (or will attach) config.log, a typescript (which has LD_LIBRARY
PATH ---you may need to more to read easily) and the result of
/sbin/ldconfig -v.
 
Mark    
(Reporter)

Comment 8

18 years ago
Created attachment 14354 [details]
config.log
(Reporter)

Comment 9

18 years ago
Created attachment 14355 [details]
result of a command (see typescript)
(Assignee)

Comment 10

18 years ago
checking for gcc... g++
checking whether the C compiler (g++  ) works... yes
checking whether the C compiler (g++  ) is a cross-compiler... no

Where's gcc?  Or at least, the cc link to it?  I'm sure this is just the
autoconf script doing a fallback check but apparently, g++ is no longer (if it
was to begin with) a straight substitute for gcc.

(Reporter)

Comment 11

18 years ago
[mstankus@localhost mstankus]$ which g++
/usr/bin/g++
[mstankus@localhost mstankus]$ g++ -v
Reading specs from /usr/lib/gcc-lib/i586-mandrake-linux/2.95.3/specs
gcc version 2.95.3 19991030 (prerelease)
[mstankus@localhost mstankus]$
                                   
(Assignee)

Comment 12

18 years ago
You'll need to install the gcc frontend compiler as well.  You may be able to
get away with a symlink to g++ but I doubt it.  I'd be very surprised if
Mandrake does not have a gcc (or egcc, egcs) binary to compile plain C programs
with.

(Reporter)

Comment 13

18 years ago
  I don't think that the problem is gcc. I can compile other programs with
gcc. I cannot get 'configure' to work.
(Assignee)

Comment 14

18 years ago
What does `which gcc` return?  The configure script is not finding gcc in your
path.  Mandrake 7.1 appears to come with both gcc 2.95 & a egcs 1.1.2 sets of
rpms.  Which ones do you have installed?

rpm -qa | egrep '(egcs|gcc)'

As I suspected, the egcs rpm from Mandrake 7.1 does not create a gcc binary.  I
just downloaded the rpm and checked.  Do you compile other programs by hand with
gcc or do you download a Mandrake/RH srpm that was configured to use CC=egcs as
the compiler?
(Reporter)

Comment 15

18 years ago
followup to questions about gcc:

[mstankus@localhost mstankus]$ which gcc
/usr/bin/gcc
[mstankus@localhost mstankus]$ rpm -qa | egrep '(egcs|gcc)'
gcc-c++-2.95.2-7mdk
gcc-cpp-2.95.2-7mdk
gcc-2.95.2-7mdk
gcc-chill-2.95.2-7mdk
gcc-colorgcc-2.95.2-7mdk
gcc-g77-2.95.2-7mdk
gcc-java-2.95.2-7mdk
gcc-libgcj-2.95.2-7mdk
gcc-objc-2.95.2-7mdk
egcs-1.1.2-28mdk
egcs-cpp-1.1.2-28mdk
egcs-g77-1.1.2-28mdk
egcs-objc-1.1.2-28mdk
egcs-c++-1.1.2-28mdk        

[mstankus@localhost mstankus]$ echo $PATH
/usr/local/bin:/bin:/usr/bin::/usr/X11R6/bin:/usr/games:/home/mstankus/bin:/usr/X11R6/bin:/usr/games:/usr/X11R6/bin:/usr/games    

>Do you compile other programs by hand with
>gcc or do you download a Mandrake/RH srpm that was configured to use CC=egcs as
>the compiler?

I downloaded an 'rpm' but not a 'srpm'.

$ echo $CC
         yields a blank line
                                        
To compile code, I type g++, never egcs nor CC=egcs.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.