remove locale code (en-US etc.) from links in new add-on version in queue notification

VERIFIED FIXED in 5.0.9

Status

--
minor
VERIFIED FIXED
9 years ago
3 years ago

People

(Reporter: aryx, Assigned: wenzel)

Tracking

unspecified
5.0.9

Details

Attachments

(1 attachment)

Please remove the locale code ("en-US") from the links in the notification which is send to editors who want to get notified about a new version. This will auto-detect the locale.

Example:

Dear editor,

An add-on you previously reviewed was just updated.


Add-on Information:

Name: Bugmail 
URL: https://addons.mozilla.org/en-US/firefox/addon/9584 

Version Number: 1.5 
Review Link: https://addons.mozilla.org/en-US/editors/review/69721 


Thanks!
Mozilla Add-ons
https://addons.mozilla.org
This is a one-time notification sent to you because you requested a follow up email regarding queue activity for Bugmail.  There is no need to unsubscribe if you don't wish to receive further mail.
Having the same issue, just got a review notification in Polish. :/

Updated

9 years ago
Duplicate of this bug: 504896

Comment 3

9 years ago
According to bug 504896, the added locale is not always en-US but it seems that it is the default locale which the author has chosen for his/her add-on.  I am changing the summary slightly.
Summary: remove locale code (en-US) from links in new add-on version in queue notification → remove locale code (en-US etc.) from links in new add-on version in queue notification
Target Milestone: --- → 5.0.9

Updated

9 years ago
Assignee: nobody → fwenzel
(Assignee)

Comment 4

9 years ago
Created attachment 393491 [details] [diff] [review]
Patch, rev. 1

This patch removes the locale from these emails and a few other, related ones. It'll result in locale sniffing working properly according to the recipient's (not: sender's) settings.
Attachment #393491 - Flags: review?(clouserw)
(Assignee)

Updated

9 years ago
Status: NEW → ASSIGNED
Attachment #393491 - Flags: review?(clouserw) → review+
(Assignee)

Comment 5

9 years ago
r48914, thanks!
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Keywords: push-needed
Resolution: --- → FIXED
Verified FIXED; tested replies and comments in the editor interface.
Status: RESOLVED → VERIFIED
(Assignee)

Updated

9 years ago
Duplicate of this bug: 510171
Keywords: push-needed
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.