Closed Bug 496600 Opened 10 years ago Closed 10 years ago

Issue with Color Management

Categories

(Core :: GFX: Color Management, defect)

1.9.1 Branch
x86
Windows Vista
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 497363

People

(Reporter: sb, Assigned: jrmuizel)

References

()

Details

(Whiteboard: [3.5Beta99testday])

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9.1b99) Gecko/20090605 Firefox/3.5b99 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9.1b99) Gecko/20090605 Firefox/3.5b99 (.NET CLR 3.5.30729)

I updated from Firefox 3.5 Beta 4 to Firefox 3.5 Beta 99 for the "Firefox 3.5 Beta99 Test Day" today and noticed an issue that is probably related to the color management.

The attached screenshot shows what a photo on Flickr looks like with Firefox 3.5 Beta 99 and Internet Explorer 8. In Firefox 3.5 Beta 4 the photo's colors looked like in Internet Explorer 8, which to me seems correct (at least they are the same I see when editing photos in Adobe Lightroom, for instance).

Reproducible: Always
Looking at the screenshot in Firefox 3.5 Beta 99, I can hardly see a difference between Firefox 3.5 Beta 99 and Internet Explorer 8.

The difference is visible in an image viewer, though.
Component: General → GFX: Color Management
Product: Firefox → Core
QA Contact: general → color-management
Version: unspecified → 1.9.1 Branch
Looks the same to me using latest trunk build and IE8.

Could you please open up about:config and tell us what the following three preferences are set to:
gfx.color_management.display_profile;
gfx.color_management.mode;2
gfx.color_management.rendering_intent;0
I can reproduce this, not sure why it happens yet.
Assignee: nobody → jmuizelaar
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
But can't reproduce it reliably. Sebastian do you have multiple monitors?
(In reply to comment #3)
> Could you please open up about:config and tell us what the following three
> preferences are set to:
> gfx.color_management.display_profile;
> gfx.color_management.mode;2
> gfx.color_management.rendering_intent;0

gfx.color_management.display_profile Standard string
gfx.color_management.mode Standard integer 2
gfx.color_management.rendering_intent Standard integer 0
(In reply to comment #5)
> Sebastian do you have multiple monitors?

I do not have multiple monitors.
Summary: [3.5Beta99testday] Issue with Color Management → Issue with Color Management
Whiteboard: [3.5Beta99testday]
It might be worth trying the trunk nightly from June 13, as it contained a qcms fix. If you can attach your monitor's color profile that could also help figure out what's going on here.
The current trunk nightly does not seem to suffer from the issue.
(In reply to comment #8)
> It might be worth trying the trunk nightly from June 13, as it contained a qcms
> fix.

Has the qcms fix in question been merged into Firefox 3.5 RC1?
(In reply to comment #10)
> Has the qcms fix in question been merged into Firefox 3.5 RC1?

I am still experiencing this issue with Firefox 3.5 RC2.
The fix has not made it into RC2. The bug with explanation why etc. is bug 497363
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 497363
You need to log in before you can comment on or make changes to this bug.